Configuring a postgres HA Cluster data source

I have a postgres datasource hosted on a HA cluster comprising 3 servers hosts , I require to add all 3 hosts to any connection strings to ensure I reach the current active node. Adding more than one host in the databases config (comma delimited) causes a timeout. Do I just have to stick with a single host and hope it's active ?

troubleshooting info?

Hi . troubleshoot info as requested
"browser-info": {
"language": "en-GB",
"platform": "Win32",
"userAgent": "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/112.0.5615.138 Safari/537.36 Edg/112.0.1722.58",
"vendor": "Google Inc."
"system-info": {
"file.encoding": "UTF-8",
"": "OpenJDK Runtime Environment",
"java.runtime.version": "11.0.13+8",
"java.vendor": "Eclipse Adoptium",
"java.version": "11.0.13",
"": "OpenJDK 64-Bit Server VM",
"java.vm.version": "11.0.13+8",
"": "Linux",
"os.version": "4.15.0-188-generic",
"user.language": "en",
"user.timezone": "GMT"
"metabase-info": {
"databases": [
"hosting-env": "unknown",
"application-database": "postgres",
"application-database-details": {
"database": {
"name": "PostgreSQL",
"version": "15.2"
"jdbc-driver": {
"name": "PostgreSQL JDBC Driver",
"version": "42.2.23"
"run-mode": "prod",
"version": {
"date": "2021-12-16",
"tag": "v0.41.5",
"branch": "release-x.41.x",
"hash": "fbfffc6"
"settings": {
"report-timezone": null

We added support for HA in a version newer than the one you’re using. Please upgrade

I tried upgrading to v0.46.4 but still seeing the same issue.
Works when I use single server in host, but fails when I comma delimit the additional ones

I'm running docker container version with seperate DB.

Is the connection string a specific format like the MongoDB one?

Please post the connection string to the db with redacted values

Hi Luiggi

I don't have a connection string as such, i'm just using the 'add database' page in the admin/Databases page. Should the 'Host' field be able to accept more than a single host?

Unlike the MongoDB set up there is no option to paste a connection string.

kind regards

Ok so it’s not the app db but rather a data source. We don’t support that yet, so you should use a pgbouncer or pgproxy on top of the db and connect Metabase to the proxy