Connecting mysql database, table name and column names mangled

I have connected a couple databases and Metabase appears to mangle names. Ex: “invoice_id” get turned into “In Voice ID”. Is there a way to turn this off? Currently we have to go into the data mode and change a bunch of fields.

1 Like

Sorry about that. Metabase tries to take a guess at making your table names “friendlier,” but it doesn’t always get it right. If you’d like to turn this behavior off (and reset your tables’ names), there’s a setting in the General section of the Admin Panel that lets you do that:

1 Like

This happened to me too and it was alarming. Thank you for the answer!

It would be handy if it worked. Some folks might be willing to give Metabase hints about where to break table names, if that were built into the setup, GUI, etc. …