Connection with Atlas MongoDB timing out

Hi team,

I've been trying to connect on my atlas mongodb serverless instance, but I couldn't.

I'm running the Metabase on premise, first I tried docker solution, then I tried the jar solution. Both return timeout.

It is not a network issue, I have whitelisted.

[2d167d60-648f-4cb1-ad2a-b8ed269065fc] 2023-06-13T13:15:29-03:00 DEBUG metabase.server.middleware.log GET /api/database 200 5.4 ms (3 DB calls) App DB connections: 0/7 Jetty threads: 6/50 (8 idle, 0 queued) (86 total active threads) Queries in flight: 0 (0 queued)
[2d167d60-648f-4cb1-ad2a-b8ed269065fc] 2023-06-13T13:15:50-03:00 ERROR metabase.api.database Cannot connect to Database
clojure.lang.ExceptionInfo: Timed out after 10.0 s {:message "Timed out after 10.0 s"}
	at metabase.driver.util$can_connect_with_details_QMARK_.invokeStatic(util.clj:159)
	at metabase.driver.util$can_connect_with_details_QMARK_.doInvoke(util.clj:132)

Does anybody face this issue and know how to proceed?

Metabase can't connect to Mongo Atlas Serverless

1 Like