CPU usage is 100% every time

Dear all,

I am troubled with the same phenomenon as the following topics.

In my case, the CPU is consumed especially after displaying the dashboard.
Also, I feel that the dashboard with the indication by geojson is more prominent.

when CPU is 100% jstack.log

Thank you :slight_smile:

Hi ssc.

I used to get the same problem (using AWS EBS with docker env). So, updating metabase to 0.31.x and disabling the metabase x-rays (in admin panel) solved this to me.

Hope it helps.

Best regards.

Eduardo
Findster Technologies

Hi Eduardo.

Thank you for helping. I 'm glad.
I tried what you taught, but it does not seem to be improved: sob:

This is running the jar on the fat client, and it seems that similar problems will occur even if running on Windows 10. (Same configuration)
Also, the same result was defined even if it was operated on VMware.

(ο½€ο½₯Ο‰ο½₯Β΄)γ‚žI will try it with Docker next time.

Hi ssc.

Sorry for insisting but are you sure that you switch off the x-rays and saved settings?

Another typo is updating java to latest version.

After all, restart your VM.

Hope it helps :slight_smile:

Eduardo

To clarify, x-rays since 0.28 are on-demand only, so if you are seeing high CPU utilization loading a specific dashboard, it’s unlikely that xrays are the root cause. We added the ability to disable them because the dashboards they produce can be expensive to run and some systems administrators didn’t like users clicking on them.

If you look at your logs, we print out how long requests take. Can you narrow your problem down using that?

1 Like

I had this issue of all the time 100% CPU and solved by enabling the following in Databases option.

This is a large database, so let me choose when Metabase syncs and scans

You will then see a new tab Scheduling. I changed DATABASE SYNCING to daily midnight and SCANNING FOR FILTER VALUES to monthly but it is up to your preference.