Currency not displaying the correct prefix

I have set the currency to symbol in my question and dashboard and default settings in my admin settings. However when the number gets very big (million and up) the currency prefix displays as code rather than symbol. How can I keep it consistently displayed as symbol?