Custom expression in metric crashing the model

Hi guys,

We came across this bug already in the version 0.33.0 and it’s not fixed 0.33.2 still seem to be an issue. I’ve tried to find this bug somewhere in the posts, but I couldn’t. Basically when you create a metric that involves a custom expression like Sum(Revenue)/Sum(Orders) and you save a metric without adding an expression name:

image

The whole model crashes so you can’t open the model page anymore. Instead of a model page there is just an empty screen:

There are no columns, no metrics and the whole model doesn’t load anymore. Would be cool to understand what’s the actual cause and if there is a bug ticket for that. In our case this model was a result of a couple of days of work, so I would love to bring it back to life somehow :smiley:. This is super confusing since the name field says (optional).

Thanks in advance!

Tomasz

Hi @tomaszmazur
It would have been great if you reported the issue when you saw it. If it already exists, then we usually find it.
This seems like a priority issue, since it breaks Metabase (a refresh doesn’t fix it), but luckily it’s requires several steps and is hidden deep within Admin sections.
I’ve created an issue - with a work-around on how to edit the metric again:
https://github.com/metabase/metabase/issues/10844

@flamber thanks a lot for the quick reply. We really appreciate it! I will check the work-around and see if it helps. Thanks a lot again for a timely response.

Edit: Worked fine :wink: Thanks again!