Custom Map (geoJSON) does not appear

Hello there!

I stumbled across a problem and I would really appreciate your help.

I try to add a custom map, by converting a .shp (Shape) file to a GeoJSON and then importing to Metabase.

By nothing works with my file which can be found here.

I know that Metabase is properly fetching the file because I can select the Properties from the dropdown menu.

I tried importing this file and it worked perfectly.

Can anyone tell me why this is happening and how to solve this problem?

Also I have Metabase macOS app v 0.37.2.

Hi @costaNull
It is actually “working”, since you can see identifier and display name columns gets filled out.
Those coordinates isn’t latitude/longitude. If you check the US states, then you’ll see it uses correct coordinates.
I would recommend using or to validate that you’re using a correct format of the GeoJSON.

Hey @flamber thanks for the prompt reply.


is showing the map correctly.

With to be honest nothing appears not sure if I am doing something wrong.

The process was the following:

  1. Downloaded the shape file from here, which is the official site for open data of Greece
  2. Converted the files with Mapshaper to GeoJson
  3. Load them to and Metabase

Any clue what I am doing wrong?

Heads up @flamber, I download a ready GeoJson from here so something is not right with the conversion from the Shape file to GeoJson from mapshaper (I suppose this is out of scope from Metabase)

Now I have a problem with the encoding of the names. Any clue how to solve this?

@costaNull Make sure that the GeoJSON is UTF-8 encoded, and make sure that your Metabase system is using UTF-8 encoding - see “Diagnostic Info” from Admin > Troubleshooting.

I think the Shape file is not intended for GeoJSON, but just basic JSON, so the coordinates are not correct. Try using a different map like this:

Hey @flamber thank you for your patience and help!

Everything is working as expected now :grin: