Custom Map not working

Hi I am trying to import a custom map for Brazil by using this geoJson File
https://raw.githubusercontent.com/codeforamerica/click_that_hood/master/public/data/brazil-states.geojson
Problem is when i try to load it gives me Invalid custom GeoJSON key: b966460b-322c-36bc-0557-f2261bb89d3b error.

I have deployed Metabase on Heroku and running 0.37.7

Hi @danialakhter
Try clicking Load again. There’s an issue open about providing more helpful errors:
https://github.com/metabase/metabase/issues/14635 - upvote by clicking :+1: on the first post

I tried clicking Again but the same result. one more thing that I noticed is that when I rollback to the previous version( 0.37.6) then it works fine. but on 0.37.7 and even on 0.37.8 it shows the same message.

@danialakhter I mean that when you click Load the first time, and see the error, then try clicking Load one more time - or even a few more times.
Not sure what could be the reason why it’s not working on Heroku at all.
Check the log to see if there’s a more detailed error - Admin > Troubleshooting > Logs.
It makes sense that 0.37.6 works, since the code was changed in 0.37.7 to harden security.

i clicked load again and again but still showing the same. the attached screenshot is the logs

@danialakhter
I think you would need to start your instance with debug logging in order to figure out why it’s failing, since I can make the URL work from my local instances without any problems, and only noticed a problem on a multi-instance, but I think that is caused by something else.
The 4th line from the bottom, which worked (PUT … 204). How did that succeed - a different URL or ?

Forth line from the bottom is when you click cancel then this lines pops up in logs.

@danialakhter Do you have other maps already? I think it’s something specific to Heroku, but the debug logs would help a lot.

it does not allow me to add any custom map and gives the same error on every JSON file.

@danialakhter Okay, you need to start with debug logging enabled:
https://www.metabase.com/docs/latest/operations-guide/log-configuration.html

@danialakhter Make sure to give the map a name before inputting an URL and clicking Load-button.

Need to be in exactly that order

1 Like

Thanks, @m2t4eus @flamber for your Support. it is working now.