Custom mapping in public link disappears


metabase has lost my custom mappings, even if they are correctly present in the admin section.

I tried to rescan, to re-enter them , I tried to change the sharing link, but nothing.
In the shared page I always see the original values ​​and not the mapped ones

this happened after upgrading to the latest version ( 0.45.2 )


I was noticing that on click a call starts, where the values ​​are correct but the mapped value is not used


Possibile che a nessuno interessi questo problema?

sorry, this is the first time I see this post. Can you please provide us with reproduction steps?

Thanks Luiggi.

here steps to reproduce my problem:
1 - i set custom mappings in admin panel. (as fig 1 in my post)
2 - when i share my dashboard with public link or iframe, i lose the mapped data (as figure 3 in my first post)


do you recall which version did this work?


I'm now upgrading to the latest version

the problem is not resolved.

Ok so what you say is: custom mappings work in dashboards but not if the dashboard is shared, is this correct?

And you also say that this worked in an older version

Let me know thanks


before version 0.45.2 it worked correctly

Are you absolutely sure this worked before 0.45.2?

I tried to use remapped values in both 0.45.1 and 0.45.2 and even in the normal dashboard I still couldn't get the filter to use remapped values.

To reproduce (using Sample Database):

  1. Go to Data model and set Reviews / Rating field type to "Category"
  2. Remap ratings from 1-5 to be something like (Awful, Bad, Meh, Good, Perfect)
  3. Create a question from "Reviews" table and save it
  4. Add to the dashboard
  5. Add filter "Text or Category" to the dashboard and connect it to "Rating"
  6. Save the dashboard

It works intermittently, but really easily loses all values.
Cannot confirm 100%, but it seems that refreshing drops remapped values sometimes.

All this to say that the bug probably existed even before and wasn't involving just public links.

1 Like

hello nemanja,
maybe the problem was born even before 0.45.1.

I remember a big update for which I also had to update the java version.
and after the mapped values no longer worked correctly.

no official answer?
:thinking: :pensive:

Hi, I just tried 44.6 and it seems that the bug is still there

I think this bug has been there since the beginning

BTW: custom mappings seem completely broken in 45-46 Custom mappings are broken · Issue #29347 · metabase/metabase · GitHub


we should insert the final fields into the database, if the bug is not fixed

update me if there news

Please subscribe to the issue in GitHub