Custom maps do not load on root domain (SOLVED)


One must go into
Metabase>Admin>General>Site Url
and change this
http:// localhost:3000
to this


Any ideas of what could be causing this behavior? Should I post to github?

Exchanging localhost:3000 for in public links and embeds loads all visualizations except for custom map geojsons. Browser inspector reveals nothing unusual simply substituting the spinner element were an extensive map rendering section should be.

Loads the custom map: http:// localhost:3000/public/question/e40de…761a7

Does NOT load the custom map: http://…761a7

Both of the above download full results>CSV, XLSX, JSON as expected.

The Metabase>Admin>Maps>Custom Maps>Edit Map window loads the geojson as expected.

Questions using custom maps load the geojsons just fine.

Logging into Metabase with localhost:3000 or in the address bar makes no difference.

Curiously sample data US map renders just fine both ways…
http:// localhost:3000/public/question/1ca9…9798b

The issue can be reproduced using the raw github geojson with the following array of values:

NAME, Alameda, Amador, Calaveras, Colusa, Contra Costa, El Dorado, Fresno, Glenn, Humboldt, Kern, Kings, Lake, Los Angeles, Madera, Mariposa, Mendocino, Merced, Monterey, Napa, Nevada, Placer, Riverside, Sacramento, San Benito, San Bernardino, San Diego, San Joaquin, San Luis Obispo, San Mateo, Santa Barbara, Santa Clara, Santa Cruz, Shasta, Siskiyou, Solano, Sonoma, Stanislaus, Sutter, Tehama, Trinity, Tulare, Tuolumne, Ventura, Yolo, Yuba
AGE, 18.6, 19, 15.5, 22.8, 18, 18, 15.8, 23, 17.8, 21.8, 11.5, 19.1, 17.9, 20.2, 15.2, 20.7, 20.7, 17.8, 18.8, 23.9, 10.9, 18, 17.6, 15, 21, 12.1, 18.3, 17.3, 13, 17.1, 16.3, 18.1, 22, 14, 18, 20, 18.2, 17, 15, 12.6, 14.7, 17, 8, 17.4, 19


Browser: Firefox 52.9.0
OS: Microsoft Windows [Version 6.0.6002]
Databases: H2 internal default, Server SQL external (joined in)
Metabase: 0.29.2
Host: Localhost:3000
Test environment: xampplite w/ Apache/2.4.29 (Win32) OpenSSL/1.0.2n PHP/7.1.13, MySQL 5.6.24

Hello - was this solved? I am having the same problem where maps don’t load on embedded dashboards

Hi @damienkopp
You’re probably experiencing this issue:

yes indeed…