Daily Alert Not Sending Results


The daily alert scheduled to send results at 4 pm is not functioning correctly. It stopped working this week, specifically on Tuesday and today, Friday. E-mails got sent out as expected any other day. The underlying query should have returned results during these instances. We have invested multiple hours so far and we couldn't reproduce this behavior.
We need urgent assistance to resolve this critical issue.

Steps Taken:

  • Verified the alert's configuration remains unchanged.
  • Successfully sent other alerts to the same e-mail address
  • Checked server and network logs for anomalies during affected periods (no significant findings).
  • Manually executed the query, and it returned expected results.
  • Checked Metabase E-Mail settings and successfully sent a test email
  • Looked for open issues, found this one: Alert not fired when query tooks too long · Issue #27789 · metabase/metabase · GitHub (not sure if it is relevant, our queries take 683ms (explain analyze, uncached!)
    We're seeking immediate support to investigate and resolve the issue as our client's production depends on these informations.

FYI: We upgraded to version v1.46.6 on July 17th

Diagnostic Info:
"browser-info": {
"language": "en-GB",
"platform": "MacIntel",
"userAgent": "Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_7) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/ Safari/537.36",
"vendor": "Google Inc."
"system-info": {
"file.encoding": "UTF-8",
"java.runtime.name": "OpenJDK Runtime Environment",
"java.runtime.version": "11.0.11+9-post-Debian-1deb10u1",
"java.vendor": "Debian",
"java.vendor.url": "openjdk-11 - Debian Package Tracker",
"java.version": "11.0.11",
"java.vm.name": "OpenJDK 64-Bit Server VM",
"java.vm.version": "11.0.11+9-post-Debian-1deb10u1",
"os.name": "Linux",
"os.version": "4.9.0-13-amd64",
"user.language": "en",
"user.timezone": "Europe/Zurich"
"metabase-info": {
"databases": [
"hosting-env": "unknown",
"application-database": "postgres",
"application-database-details": {
"database": {
"name": "PostgreSQL",
"version": "11.12 (Debian 11.12-0+deb10u1)"
"jdbc-driver": {
"name": "PostgreSQL JDBC Driver",
"version": "42.5.1"
"run-mode": "prod",
"version": {
"date": "2023-06-29",
"tag": "v1.46.6",
"branch": "release-x.46.x",
"hash": "1bb88f5"
"settings": {
"report-timezone": "Europe/Zurich"

First you need to upgrade asap to 46.6.4. If you’re using enterprise or pro plan, please contact us to help at Metabase dot com as you have priority support


Re priority support: I'm getting a prompt to enter our metabase cloud URL. We're self-hosted, I don't have a metabase cloud url to login