Dashboard fails to load after upgrading metabase

old version: v0.33.6
new version: v0.34.3
hosting platform: AWS EBS
metabase DB: postgres
data source: postgres
browser: Chrome 80.0.3987.132 (Official Build) (64-bit)

Prior to upgrade all of my dashboard load and work fine; after the upgrade 2 of the dashboard fail. I don’t see any errors in the metabase EBS logs, but in the browser console I see the following errors…

react_devtools_backend.js:6 TypeError: Cannot read property ‘isNumeric’ of null
at app-main.bundle.js?a10c9974cc03fead96be:5
at Array.every ()
at O (app-main.bundle.js?a10c9974cc03fead96be:5)
at t.value (app-main.bundle.js?a10c9974cc03fead96be:5)
at c.performInitialMount (vendor.bundle.js?a10c9974cc03fead96be:1)
at c.mountComponent (vendor.bundle.js?a10c9974cc03fead96be:1)
at Object.mountComponent (vendor.bundle.js?a10c9974cc03fead96be:1)
at Object.mountComponent (react_devtools_backend.js:32)
at Object.e. [as mountComponent] (react_devtools_backend.js:32)
at c.performInitialMount (vendor.bundle.js?a10c9974cc03fead96be:1)
r @ react_devtools_backend.js:6
(anonymous) @ app-main.bundle.js?a10c9974cc03fead96be:5
M @ vendor.bundle.js?a10c9974cc03fead96be:1
u._invoke @ vendor.bundle.js?a10c9974cc03fead96be:1
e. @ vendor.bundle.js?a10c9974cc03fead96be:1
r @ app-main.bundle.js?a10c9974cc03fead96be:5
(anonymous) @ app-main.bundle.js?a10c9974cc03fead96be:5
Promise.then (async)
r @ app-main.bundle.js?a10c9974cc03fead96be:5
(anonymous) @ app-main.bundle.js?a10c9974cc03fead96be:5
t @ app-main.bundle.js?a10c9974cc03fead96be:5
(anonymous) @ app-main.bundle.js?a10c9974cc03fead96be:5
value @ app-main.bundle.js?a10c9974cc03fead96be:5
e.notifyAll @ vendor.bundle.js?a10c9974cc03fead96be:1
close @ vendor.bundle.js?a10c9974cc03fead96be:1
closeAll @ vendor.bundle.js?a10c9974cc03fead96be:1
perform @ vendor.bundle.js?a10c9974cc03fead96be:1
perform @ vendor.bundle.js?a10c9974cc03fead96be:1
perform @ vendor.bundle.js?a10c9974cc03fead96be:1
M @ vendor.bundle.js?a10c9974cc03fead96be:1
closeAll @ vendor.bundle.js?a10c9974cc03fead96be:1
perform @ vendor.bundle.js?a10c9974cc03fead96be:1
batchedUpdates @ vendor.bundle.js?a10c9974cc03fead96be:1
batchedUpdates @ vendor.bundle.js?a10c9974cc03fead96be:1
dispatchEvent @ vendor.bundle.js?a10c9974cc03fead96be:1

Uncaught (in promise) TypeError:
Cannot read property ‘getHostNode’ of null
at Object.getHostNode (vendor.bundle.js?a10c9974cc03fead96be:1)
at c.getHostNode (vendor.bundle.js?a10c9974cc03fead96be:1)
at Object.getHostNode (vendor.bundle.js?a10c9974cc03fead96be:1)
at Object.updateChildren (vendor.bundle.js?a10c9974cc03fead96be:1)
at Z._reconcilerUpdateChildren (vendor.bundle.js?a10c9974cc03fead96be:1)
at Z._updateChildren (vendor.bundle.js?a10c9974cc03fead96be:1)
at Z.updateChildren (vendor.bundle.js?a10c9974cc03fead96be:1)
at Z._updateDOMChildren (vendor.bundle.js?a10c9974cc03fead96be:1)
at Z.updateComponent (vendor.bundle.js?a10c9974cc03fead96be:1)
at Z.receiveComponent (vendor.bundle.js?a10c9974cc03fead96be:1)

Hi @notreallyhere
Please post “Diagnostic Info” from Admin > Troubleshooting.
Are you using Cloudfront cache or Cloudflare or anything similar to that?
If you reproduce the failing dashboard - by creating a new dashboard and add similar cards - does the new dashboard work? If not, can you pin-point the question that fails?

Thanks for looking into this.
No I’m not using any cache / CDN.
Diagnostic info at the bottom of this message…

The questions all work individually. When I attempt to recreate the dashboard I hit the same error, but only when I save a default value for one of the dashboard parameters and then after saving attempt to alter the value of that default parameter. The 2nd save fails and if I cancel & reload the page the dashboard hangs on the loading spinner.

The following error message also appears in the log multiple times

[40dbc287-4fc6-4b21-9257-a68f8e0cd4aa] 2020-03-20T21:21:41+09:00 ERROR metabase.models.params Could not find matching Field ID for target: [:dimension [:template-tag SECCODE]]

  "browser-info": {
    "language": "en-GB",
    "platform": "Win32",
    "userAgent": "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/80.0.3987.149 Safari/537.36",
    "vendor": "Google Inc."
  "system-info": {
    "java.runtime.name": "OpenJDK Runtime Environment",
    "java.runtime.version": "11.0.5+10",
    "java.vendor": "AdoptOpenJDK",
    "java.vendor.url": "https://adoptopenjdk.net/",
    "java.version": "11.0.5",
    "java.vm.name": "OpenJDK 64-Bit Server VM",
    "java.vm.version": "11.0.5+10",
    "os.name": "Linux",
    "os.version": "4.14.138-89.102.amzn1.x86_64",
    "user.language": "en",
    "user.timezone": "UTC"
  "metabase-info": {
    "databases": [
    "hosting-env": "elastic-beanstalk",
    "application-database": "postgres",
    "application-database-details": {
      "database": {
        "name": "PostgreSQL",
        "version": "11.5"
      "jdbc-driver": {
        "name": "PostgreSQL JDBC Driver",
        "version": "42.2.8"
    "run-mode": "prod",
    "version": {
      "date": "2020-02-25",
      "tag": "v0.34.3",
      "branch": "release-0.34.x",
      "hash": "1a83edb"
    "settings": {
      "report-timezone": null

@notreallyhere Would I be correct to assume that you’re using Saved Questions somewhere on that dashboard and tried to connect filters to those cards? If yes, then it’s a known issue:
https://github.com/metabase/metabase/issues/9802 - upvote by clicking :+1: on the first post

@flamber it is a saved Question, but it is not nested. I think #9802 requires the question to be nested when linking to the dashboard parameters.

@notreallyhere Okay, can you reproduce with Sample Dataset and provide the steps?

@flamber frustratingly I can’t recreate the error on the Sample Dataset. I also tried creating my own anonymised subset of data in postgres (the same type as the original data source) however I can’t reproduce the error that way either.
I can recreate the error in a different Metabase instance, with the entire set of data copied to a different postgres instance… so I suspect that the size of the dataset in combination with the SQL used in the Question may be causing the problem.
Is there a way of debugging this myself? – Is there a way to enable detailed logging on the Web client and backend api when running on AWS ElasticBeanstalk, or do I have to grab the opensource project and start from there?

Also I have narrowed down the issue to only happen when the following are combined:

  • a dashboard datetime (all options) filter is set with a default value
  • 2 or more charts with each showing more than 1 question
  • a large postgres data source