Dashboard filter fields stopped working on 0.19.0

I had a couple of dashboard filters working, but after the 0.19.0 update now they keep working but i can’t edit them.
It works and filters the data but when i try to edit the fields it does not show valid fields.

There is not JS console errors.

Can you try creating a new dashboard with the same cards + filters? i.e. is it just the old dashboard that isn’t working or is it something more basic?

What I really want to do is use the Filter Field type of the SQL Templates.

So i created a new sql template

SELECT count(*) AS "count" FROM "public"."charge" LEFT JOIN "public"."payment_transaction" "payment_transaction__via__payment_transaction_id" ON "public"."charge"."payment_transaction_id" = "payment_transaction__via__payment_transaction_id"."id" WHERE {{status}}

And tried to add that question to a new dashboard with a category filter name status, but i get this

what’s the type of status in your schema?

string

does it have a field type or special type? (check the data model tab in the admin or find the field in data reference)

No, is just a string.

Ok, I think we’re re-produced it. This is definitely a P1 bug, and we’ll release a patch release (0.19.1) once we’ve fixed it.

Nice, thank you!! Looking forward to it and learn Clojure !

This is fixed in 0.19.1 which we just released.

1 Like

It did not work well. I’ll update the bug report later.

oh dear.

please let us know what went sideways for you

Not sameer, but I understood from the markup in this comment that field filters would detect the various values which are found in a given column and allow the user to select from among those values to filter their data. Also, I forget where I found the other markup, but I understood from a different markup that field filters would also allow filtering by two different selected values (i.e. view all results from users 1 and 2, but not 3 and 4).

Given that the 19.1 field filters seem rather similar to text filters, I’m somewhat confused as to what exactly it does? Did I misunderstand? Is this merely a prototype and in future releases it will be changed to behave more closely to how I described? I’m also having trouble in that when I tried to set a field filter, the dashboard detects one as an “ID”, one as an “other category”, and one not at all. Not sure if any of this is exactly sameeer’s original question, but I would appreciate any help or enlightenment in this regard. Thanks!

Sorry, this got a little carried away. Maybe I should have started a new topic…?

No worries.

The core idea of a “filter field” is the ability to create a hybrid between a SQL backed question and our GUI questions. It connects a template tag to an underlying field in a table, so that we can treat that tag as a dimension through out the rest of the application. Of most immediate interest is that his allows Metabase to link a SQL backed card in a dashboard to a filter widget on that dashboard. In the future, we’ll continue to expand on the things that Metabase will automatically be able to do with hybrid cards.

One thing that got lost in the ~2k Lines of Code in the 0.19 version of SQL templates is using the field values of an underlying field – https://github.com/metabase/metabase/issues/3120. If a given filter widget is linked to the same underlying field via a GUI generated card, it’ll all work correctly. If you’re only linking SQL backed bards, we won’t pull out the underlying values until #3120 is closed. It’s definitely something that we overlooked and we’ll be fixing it asap.

Anything new on this? I’m having issues with filters in dashboard (no new values).