Dashboard filters not showing all values

Hey there,

On filters in dashboards, earlier we used to see all the filters values while selecting, now it only shoes default values.
image

Hi @ankitsugandhi

Post “Diagnostic Info” from Admin > Troubleshooting.

And be “earlier we used to”, do you mean something happened after you upgraded? From which version?

The field used for the filter, what is the option set to?
Admin > Data Model > (database) > (table) > (column) :gear: > “Filtering on this field”

Hey man,

While selecting filters, I did set default values to different options(WATCH,CA,OTHERS). If I want to select only one option at a time and then change to other option I am not able to see other options. The screenshot which I have shown is when I have selected only one option, other option (i.e CA , OTHERS) I am unable to see. So how can I select multiple options for a filter?

@ankitsugandhi Please provide the information I requested above.

Hi,
Here is the screenshot.

@ankitsugandhi

  1. Post “Diagnostic Info” from Admin > Troubleshooting.
  2. And be “earlier we used to”, do you mean something happened after you upgraded? From which version?
  1. Diagnostic Info :
    {
    “browser-info”: {
    “language”: “en-GB”,
    “platform”: “Win32”,
    “userAgent”: “Mozilla/5.0 (Windows NT 6.3; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/86.0.4240.198 Safari/537.36”,
    “vendor”: “Google Inc.”
    },
    “system-info”: {
    “file.encoding”: “UTF-8”,
    “java.runtime.name”: “OpenJDK Runtime Environment”,
    “java.runtime.version”: “11.0.7+10-post-Ubuntu-2ubuntu218.04”,
    “java.vendor”: “Ubuntu”,
    “java.vendor.url”: “https://ubuntu.com/”,
    “java.version”: “11.0.7”,
    “java.vm.name”: “OpenJDK 64-Bit Server VM”,
    “java.vm.version”: “11.0.7+10-post-Ubuntu-2ubuntu218.04”,
    “os.name”: “Linux”,
    “os.version”: “5.3.0-1017-aws”,
    “user.language”: “en”,
    “user.timezone”: “Asia/Kolkata”
    },
    “metabase-info”: {
    “databases”: [
    “h2”,
    “mysql”
    ],
    “hosting-env”: “unknown”,
    “application-database”: “h2”,
    “application-database-details”: {
    “database”: {
    “name”: “H2”,
    “version”: “1.4.197 (2018-03-18)”
    },
    “jdbc-driver”: {
    “name”: “H2 JDBC Driver”,
    “version”: “1.4.197 (2018-03-18)”
    }
    },
    “run-mode”: “prod”,
    “version”: {
    “date”: “2020-10-26”,
    “tag”: “v0.37.0.2”,
    “branch”: “release-x.37.x”,
    “hash”: “ba7be09”
    },
    “settings”: {
    “report-timezone”: null
    }
    }
    }

  2. I don’t remember whether I upgraded my version or not

@ankitsugandhi

  1. Try upgrading to latest release 0.37.2
  2. And migrate away from H2 if you are using Metabase in production:
    https://www.metabase.com/docs/latest/operations-guide/migrating-from-h2.html
  3. How many distinct values does the column have?

@flamber:

After upgrading from version 0.36.7 to v0.37.2 this problem happens to my users as well. All different kind of Dashboard filters are affected.
All users did see in the drop-down field the possible entries of the column the Filter is connected to:

Let’s take an example: I do have users which are assigned to a group (Let’s call the group ABC). I created a dashboard for them that contains some filters. I gave the group ABC the “view collection permission”.
In order that the user had access to the filter values over the dashboard, I changed to type of the column to category (under admin --> Data model --> Database --> table etc.). In the field settings, I made sure that the “Filtering on this field” is set to “A List of all values”. I also clicked on “Re-Scan this field”, because sometimes the filter didn’t work until i rescanned this field.
The strange thing is also, that the admins (as me) do not have the problem (filter values are shown with my user), only the users to have the problem.

I checked with the user, and they get a lot of error messages when opening the dashboard. Before (what i assume) these errors weren’t here.

When the user clicks on a filter he gets the following error message “You don’t have the permission to do that”.

The “error” can be fixed by giving the user/the group ABC access to the underlying tables of the dashboard under Admin --> Permission --> Data permission.

There are 2 problems I am facing now:

  • We do have a lot of dashboards and I have to go 1 by 1 through all the dashboards and give the potential users of this dashboard “Grant unrestricted access” (under admin --> Permission --> Data permission etc.) to the underlying views/tables
  • With giving a group of people “Grant unrestricted access” they can now also do querries on this table as well and manipulate data and save questions based on the table i had do give them

@flamber Therefore my question. did something change from version 0.36.7 to v0.37.2 regarding Dashbaord filters and the content of those filters. Because I want to avoid giving users to much access. They should only have access to 1 Dashboard, nothing more:

Here my Diagnostic info:
{
“browser-info”: {
“language”: “en”,
“platform”: “Win32”,
“userAgent”: “Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/86.0.4240.198 Safari/537.36”,
“vendor”: “Google Inc.”
},
“system-info”: {
“file.encoding”: “UTF-8”,
“java.runtime.name”: “OpenJDK Runtime Environment”,
“java.runtime.version”: “11.0.7+10”,
“java.vendor”: “AdoptOpenJDK”,
“java.vendor.url”: “https://adoptopenjdk.net/”,
“java.version”: “11.0.7”,
“java.vm.name”: “OpenJDK 64-Bit Server VM”,
“java.vm.version”: “11.0.7+10”,
“os.name”: “Linux”,
“os.version”: “4.14.35-1902.302.2.el7uek.x86_64”,
“user.language”: “en”,
“user.timezone”: “GMT”
},
“metabase-info”: {
“databases”: [
“oracle”,
“firebird”,
“mysql”,
“postgres”,
“presto”,
“h2”
],
“hosting-env”: “unknown”,
“application-database”: “postgres”,
“application-database-details”: {
“database”: {
“name”: “PostgreSQL”,
“version”: “11.9”
},
“jdbc-driver”: {
“name”: “PostgreSQL JDBC Driver”,
“version”: “42.2.8”
}
},
“run-mode”: “prod”,
“version”: {
“date”: “2020-11-16”,
“tag”: “v0.37.2”,
“branch”: “release-x.37.x”,
“hash”: “25e5f70”
},
“settings”: {
“report-timezone”: “UTC”
}
}
}

@lst Sounds like you are seeing this issue - and/or some of the referenced issues:
https://github.com/metabase/metabase/issues/13832 - upvote by clicking :+1: on the first post

0.37.2 is major version shift from 0.36.7 - I would recommend that you revert to your backup and stay with 0.36.8 until the issue has been resolved.

1 Like

Thanks for your quick reply @flamber . Thanks for the recommendation, we will revert back to 0.36.8.
Will this issue be solved any time soon, or do you wait of how many upvotes it gets? Don’t want to miss to much versions for the best tool I’ve ever seen for data analytics. :slight_smile:

Hi @flamber: Do you know maybe when this issue will be fixed?

As we are desperately waiting that this issue will be fixed, so we can update to 0.38.
Thanks in advance for the feedback.

@lst Currently no.