Dashboard inaccessible on specific joins, invalid MBQL clause

Version 0.48.0
openjdk11.0.21 2023-10-17

Issue appears similar to Join is removed with "Removing invalid MBQL clause" joining two columns together with the same field ID · Issue #31769 · metabase/metabase · GitHub

I'm getting a specific error as the following:

Invalid output: {:stages [{:joins [{:conditions [["invalid MBQL clause: [:= {:lib/uuid "eb447715-6d66-49e2-bfa4-adde66544e17"} [:field {:base-type :type/BigInteger, :effective-type :type/BigInteger, :lib/uuid "aeaab05b-684f-4717-b023-7e91d00ca3c0"} 1466] [:field {:base-type :type/, :effective-type :type/, :join-alias "users - user_id", :lib/uuid "4f9da36d-cd6d-4e47-89c6-c6fc916fd9fb"} 1488]]" "invalid MBQL clause: [:= {:lib/uuid "eb447715-6d66-49e2-bfa4-adde66544e17"} [:field {:base-type :type/BigInteger, :effective-type :type/BigInteger, :lib/uuid "aeaab05b-684f-4717-b023-7e91d00ca3c0"} 1466] [:field {:base-type :type/, :effective-type :type/, :join-alias "users - user_id", :lib/uuid "4f9da36d-cd6d-4e47-89c6-c6fc916fd9fb"} 1488]]"]]}], :source-card ["missing required key"]}]}

If I try to recreate the question, joining the two tables together, the join disappears.

I'm able to recreate with a SQL Query with no issue.

Here is where I try to join, and you can see the header changes, but no join options are available

Hello! I have the same bug.
I installed version 0.47.9 via quickstart for Docker and everything worked fine.
But after migrating the database to Postgres and updating to version 0.48, this bug appeared.
I'm creating a new Question and Join data. The Join data is immediately disappear in the visual editor of the Question, but remains in the code when I click View SQL. In the visualization I see the Join data.
If I save this Question and add another Join, the previous one disappears in the View SQL.
I tried to create a clean database in Prostgres and send a fresh latest Metabase to it. But this bug remains.
Some data Join normally, and some with such a bug.
I haven’t tested it yet with installing version 0.48 via quick start with the built-in H2 database.

Update. I deployed latest Metabase v0.48.1 via quickstart for Docker with the built-in H2 database and do not see this bug.. Has this bug been fixed in the new version 0.48.1?
I updated the main container that is connected to the Postgres database from v0.48 to v0.48.1 and this bug is gone.

As an Update, this issue has been fixed by update 0.48.1.