Dashboard URL parameters not working in 0.24.1

We’ve realized that, after migrating from version 0.23.1 to 0.24.1, the parameters we used to set the Dashboard mode through its URL (Fullscreen, night mode and auto-refresh) are not working anymore.

The syntax we’re adding at the end of the URL (and that was working fine on 0.23.1) is “#fullscreen&refresh=60&night”, but unfortunately, it’s not working in none of our browsers (Chrome, Firefox and IE).

This is a problem for us, as long as we have more Dashboards than screens, so in some of them we’re using a Chrome plugin to switch between tabs (with one Dashboard loaded in each of them). It did the trick for us until now, as long as we could launch Chrome in kiosk mode, indicating the Full URL of the Dashboards + the parameters. Then, after every switch between the tabs, the full screen and night mode was kept as specified. Now, they’re launched without full screen & night mode, and even if you set it manually, once they’re switched, Dashboards get out of full screen mode.

Have any of you guys noticed this issue?
Thanks in advance!

P.S. Congrats for your job with Metabase. It has become a MUST in Reporting!! :wink:

Sorry for the trouble. I just filed an issue for this:

So glad to hear that Metabase has been helpful for you and your team!

Thank you Maz! I’ll follow this issue on GitHub :wink:

I just wrote this in the GH issue, but I’ll paste it here:

So we looked into this and the URL parameters do work in every case except if you are already on a dashboard and then manually append the parameters to the URL. In that scenario, nothing happens, unless you’re using Safari or Opera (on MacOS at least), in which case it seems to work unpredictably; so this appears to be a browser quirk.

@lagoGT, do the parameters work for you if you open a new browser window and type the full URL path including the parameter options? E.g. if you navigate directly to something like https://metabase.mywebsite.com/dashboard/7#fullscreen&refresh=60&night, do the parameters work then? In our testing, that did work consistently.

You’re totally right. This way it works as expected! :wink:
I’m still not sure why it wasn’t working when launching the full URL + parameters from a cmd file in kiosk mode, but it seems to be Ok now.
Thank you @maz for pointing me in the right direction!

1 Like

Glad it’s working!

I had this problem and It was an issue with me still running java 7 on the Metabase server. Update to java 8 and this java concurrency issue disappears