Data Labels not showing up properly inside the graph

Hi there,

In the last few days I have noticed the data labels related to two different segments I am overlaying in Metabase don't provide the two different values, despite being shown properly in the graph below:

Can you please let me know if this is a bug you are working to resolve or something else?


Hi @ff9991
Post "Diagnostic Info" from Admin > Troubleshooting. Every time you open a topic, I'll ask for this.
I don't think I understand. Can you explain in more details what the problem is?

Hi flamber,

Thanks for this.

Basically, I get the same naming for two different questions that I have called differently in my visualisation options (attaching the images to make it clearer):

Please find below the troubleshooting info and sorry for not including it:

"browser-info": {
"language": "en-GB",
"platform": "Win32",
"userAgent": "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/90.0.4430.212 Safari/537.36",
"vendor": "Google Inc."
"system-info": {
"file.encoding": "UTF-8",
"": "OpenJDK Runtime Environment",
"java.runtime.version": "11.0.11+9",
"java.vendor": "AdoptOpenJDK",
"java.vendor.url": "",
"java.version": "11.0.11",
"": "OpenJDK 64-Bit Server VM",
"java.vm.version": "11.0.11+9",
"": "Linux",
"os.version": "4.14.225-168.357.amzn2.x86_64",
"user.language": "en",
"user.timezone": "GMT"
"metabase-info": {
"databases": [
"hosting-env": "unknown",
"application-database": "postgres",
"application-database-details": {
"database": {
"name": "PostgreSQL",
"version": "12.5"
"jdbc-driver": {
"name": "PostgreSQL JDBC Driver",
"version": "42.2.18"
"run-mode": "prod",
"version": {
"date": "2021-04-27",
"tag": "v0.39.1",
"branch": "release-x.39.x",
"hash": "6beba48"
"settings": {
"report-timezone": "Europe/London"

Let me know if this is clearer?


@ff9991 You're seeing this issue: - upvote by clicking :+1: on the first post
Just as a note, I read "data labels" as "data point values", but you're referring to tooltips.

Upvoted now, thanks for that and sorry for the wrong terminology!