"Data" tab for chart in dashboard

Hi there, people!
I was here using the following chart in a native question:

I formatted it in the Data tab, so it would look like percentage - at first, I used data ranging from 0 to 1 and set the numbers column to “percentage”. In the question, it worked just fine. But, when adding it to a dashboard, I can’t see the data tab - therefore, I can’t format my data as percentage, neither can I add a suffix or multiply it by a constant, even if that is already done in the question. In that scenario, y axis gets formatted like number, not like percentage, no matter what I do.

My suggestion is to either add the data tab in the dashboard visualization for charts, or honor the question visualization settings in that regard.

Thanks for the great job so far (and sorry if this is a dupe)!

I think there were some issues with earlier versions, but I cannot replicate your issue in 0.31.2

That’s not to say, that having the Data option wouldn’t be nice, but that’s a feature request.

In the Native Query, Options for y and y2 set to Percentage under Data, and Stacked under Display:

SELECT 1 AS 'x', 0.8 AS 'y', 0.1 AS 'y2'
SELECT 2 AS 'x', 0.1 AS 'y', 0.1 AS 'y2'
SELECT 3 AS 'x', 0.3 AS 'y', 0.1 AS 'y2'
SELECT 4 AS 'x', 0.6 AS 'y', 0.1 AS 'y2'
SELECT 5 AS 'x', 0.2 AS 'y', 0.1 AS 'y2'


1 Like

Hi, there. Thanks for the reply.

I tried to reproduce your example here (lazy of mine not trying to provide such a query as you did, sorry).
Worked fine. I then tried to re-add my own question to the dashboard. The newly added question worked fine as well, but the pre-added one didn’t. I guess the issue is somewhere else.

Thanks, anyway, you helped me to solve the issue.

I would guess because the card was added to a dashboard before you had done the Data>Option thingy?
I usually edit the card in the dashboard and click Reset - then everything seems to return to the settings I’ve defined in the actual question.

1 Like

Yes, it was added way before. Thanks for the guidance!