Data Visibility

In my data models, the fields with visibility set to “Only in Detail Views” are only being respected by admin accounts. If I log in with any other type of account every column is visible in table views. I’ve tried flipping the visibility back and forth between “Everywhere”, but that hasn’t had any effect. Are there different settings for different account types I’m missing?

I’m running enterprise edition based on 0.33.3

Hi @harrywynn
I cannot reproduce your issue. Where are you seeing the column that was set to “Only in Detail Views”?
What type of question is it? If Native, then “Visibility” has no impact.
Do you have cache enabled, so maybe you’re seeing an older query?

Hey @flamber

I do have caching enabled, but flipping it on/off doesn’t change anything. This is just browsing one of my tables.

This is part of the model:

Here is what the admin account sees:

Here is what a non-admin account sees:

So the visibility settings are respected on my admin account, but no other types.

@harrywynn
Which version of Metabase? Which database type are you querying?
I have tried multiple things, but I cannot reproduce.
What type of permissions does the non-admin have? Admin > Permissions > Data and Collection

@flamber
I’m running the enterprise edition based on 0.33.3, which seems to be the issue. The tables that are sandboxed don’t respect the visibility when set to detail only - they do work for either everywhere or not included. If the table isn’t sandboxed then they respect all visibility settings.

@harrywynn
So you’re using version 1.33.3 of Enterprise Edition? https://hub.docker.com/r/metabase/metabase-enterprise/tags
I would recommend that you send a mail to support at metabase.com for support with Enterprise Edition.

@flamber
I did after I realized what was going on - thanks for spinning me in the right direction.