Database connection timeout

I'm hosting our metabase instance on AWS Elastic Beanstalk. Followed the
guide and it worked okay.

The only issue I have is that I cannot connect to our PostgreSQL database. I tried whitelisting the IPs as suggested here but I'm still getting a timeout error.

Any help will be appreciated.

  "browser-info": {
    "language": "en-US",
    "platform": "Linux x86_64",
    "userAgent": "Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/89.0.4389.114 Safari/537.36",
    "vendor": "Google Inc."
  "system-info": {
    "file.encoding": "UTF-8",
    "": "OpenJDK Runtime Environment",
    "java.runtime.version": "11.0.11+9",
    "java.vendor": "AdoptOpenJDK",
    "java.vendor.url": "",
    "java.version": "11.0.11",
    "": "OpenJDK 64-Bit Server VM",
    "java.vm.version": "11.0.11+9",
    "": "Linux",
    "os.version": "4.14.232-176.381.amzn2.x86_64",
    "user.language": "en",
    "user.timezone": "GMT"
  "metabase-info": {
    "databases": [
    "hosting-env": "unknown",
    "application-database": "h2",
    "application-database-details": {
      "database": {
        "name": "H2",
        "version": "1.4.197 (2018-03-18)"
      "jdbc-driver": {
        "name": "H2 JDBC Driver",
        "version": "1.4.197 (2018-03-18)"
    "run-mode": "prod",
    "version": {
      "date": "2021-06-15",
      "tag": "v0.39.4",
      "branch": "release-x.39.x",
      "hash": "f538050"
    "settings": {
      "report-timezone": null

Hi @ishuah
You are not using Metabase Cloud, so those IPs have no effect for you. You need to add your own IPs.
And your "Diagnostic Info" does not indicate that your are using EB, and if you are, then you didn't follow the guide completely, since Metabase is using H2 as the application database instead of Postgres.
I would recommend that you redo the setup and make sure that Metabase does not use H2.

1 Like