Date issue between metabase & snowflake?

Has anyone seen this before? Metabase results are converting my date/timestamps & idk why?


Hi @rjn2

Post “Diagnostic Info” from Admin > Troubleshooting.

Snowflake does not support Report Timezone:

You’re likely seeing this: - upvote by clicking :+1: on the first post

  "browser-info": {
    "language": "en-US",
    "platform": "MacIntel",
    "userAgent": "Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_7) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/88.0.4324.150 Safari/537.36",
    "vendor": "Google Inc."
  "system-info": {
    "file.encoding": "UTF-8",
    "": "OpenJDK Runtime Environment",
    "java.runtime.version": "11.0.10+9",
    "java.vendor": "AdoptOpenJDK",
    "java.vendor.url": "",
    "java.version": "11.0.10",
    "": "OpenJDK 64-Bit Server VM",
    "java.vm.version": "11.0.10+9",
    "": "Linux",
    "os.version": "4.14.186-146.268.amzn2.x86_64",
    "user.language": "en",
    "user.timezone": "GMT"
  "metabase-info": {
    "databases": [
    "hosting-env": "unknown",
    "application-database": "postgres",
    "application-database-details": {
      "database": {
        "name": "PostgreSQL",
        "version": "11.7"
      "jdbc-driver": {
        "name": "PostgreSQL JDBC Driver",
        "version": "42.2.8"
    "run-mode": "prod",
    "version": {
      "date": "2021-02-11",
      "tag": "v1.37.9",
      "branch": "release-x.37.x",
      "hash": "a9a7fc8"
    "settings": {
      "report-timezone": null

hmm, so this isnt something i can currently fix? its quite problematic.

@rjn2 I’m guessing that you’re using Metabase Cloud? If yes, then no, we currently don’t support custom environment variables per instance.

:frowning_face: - is that something you plan on supporting in the future? what would be my way around this? not use metabase cloud?

@rjn2 We want to fix all issue - including the linked issue. And we are working on adding more features to our Cloud too, but we are a fairly small team, so it will take some time.
As it is right now, I don’t see any other workaround than hosting yourself.

Okay, thanks!