Date not showing on query results (even on xray)

Hi,
I am not getting the date values on any of my query results. Started when I updated to 0.34.3.

image

Metabase Version: Metabase 0.34.3
Database: Oracle 11g

image

What could be the issue?

Hi @kenince
Please post “Diagnostic Info” from Admin > Troubleshooting.
Make sure that you update ojdbc version 19c:
https://www.metabase.com/docs/latest/administration-guide/databases/oracle.html

{
  "browser-info": {
    "language": "en-US",
    "platform": "Win32",
    "userAgent": "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/80.0.3987.163 Safari/537.36",
    "vendor": "Google Inc."
  },
  "system-info": {
    "java.runtime.name": "Java(TM) SE Runtime Environment",
    "java.runtime.version": "1.8.0_221-b11",
    "java.vendor": "Oracle Corporation",
    "java.vendor.url": "http://java.oracle.com/",
    "java.version": "1.8.0_221",
    "java.vm.name": "Java HotSpot(TM) 64-Bit Server VM",
    "java.vm.version": "25.221-b11",
    "os.name": "Linux",
    "os.version": "2.6.39-400.312.2.el6uek.x86_64",
    "user.language": "en",
    "user.timezone": "Indian/Comoro"
  },
  "metabase-info": {
    "databases": [
      "h2",
      "oracle"
    ],
    "hosting-env": "unknown",
    "application-database": "h2",
    "application-database-details": {
      "database": {
        "name": "H2",
        "version": "1.4.197 (2018-03-18)"
      },
      "jdbc-driver": {
        "name": "H2 JDBC Driver",
        "version": "1.4.197 (2018-03-18)"
      }
    },
    "run-mode": "prod",
    "version": {
      "tag": "v0.34.3",
      "date": "2020-02-25",
      "branch": "release-0.34.x",
      "hash": "1a83edb"
    },
    "settings": {
      "report-timezone": null
    }
  }
}

My database version is 11g and not 19c.

@kenince Database version has nothing to do with ojdbc version. Just try to update ojdbc8.jar to 19c.
And then you should look into migrating away from H2 at some point:
https://www.metabase.com/docs/latest/operations-guide/migrating-from-h2.html

1 Like

Yeah, that’s part of the plan. Last time I tried migrating I lost my questions and dashboards.

Doing it now, I will update you in a few.

So I have updated to 0.31.5 and added JDBC driver ojdbc8.jar.

This has worked!

Thanks a lot @flamber

How can I mark this as solved?