Dev Environment under Windows 10


I've tried several times to setup a development environment on Windows 10 and miserably failed.

I've looked for comunity post here, i've searched on google, i tried to sue char GPT3.5 through openAI, i tried chat GPT 4 throught bingAI also and never success to get somehting working.

So here i am, hoping the comunity to help me resolve this situation.

I'm using Windows 10 and Intelij IDEA from Jetbrains.
We have METABASE running on a Debian Virtual Machine on the same local network as my computer.

I want to be able to have a development version of metabase in local on my computeur, not affecting the one running on the local network.

Can someone be my mentor and help me figuring out how to setup everything ?

I'de be so grateful !!!

Best regards


can you tell us where/which step you're failing on?

Hi Luiggi,

Of course i can give any informations that could hepl you having a better understanding of my situation.

I created a new project in Intelij IDEA and when times came to executing command like yarn install , i have error in console about grep not being a known command.
Well i should have seen it coming as grep is a unix command and currently i'm under Windows 10 and the script are being launch in a powershell terminal.

So i tried to install WSL (Windows Subsystem for Linux) Debian, followed the guide and got some error while installing brew gcc, which prevent me to properly install Clojure i guess and from there i tried to mess with sooooo much things that i messed everythings up and i'm willing to start again from scratch.

So i decided to ask for help before starting again, to make each step the right way under the control of a "knower" :slightly_smiling_face:

Best regards

  1. use wsl
  2. follow the docs on how to install the dependencies (node yarn Java clojure)
  3. raise the project with “yarn dev”


1st of all thanks you for helping so far. @Luiggi i re started everything from scratch and got it finally working.

I have now a local working version of metabase running through the command "yarn dev"

I wanted to add an ORACLE database, so i followed the docs about it.
I downloaded the ojdbc8.jar and put it in the "plugins" directory that was created while i ran yarn dev into the "metabase" directory.

The connector is never shown as an option in the dropdown menu where you can add a database in metabase.

Would you help me figuring it out ? Or anyone also ....

Best regards

I found that i can run "./bin/ oracle" command, then i ran yarn dev.

In the page to add a new database i eventually have oracle but when i try to add one i have an error message.
ORA-17002: I/O error: java.lang.NoClassDefFoundError: Could not initialize class, connect lapse 0 ms., Authentication lapse 0 ms. ORA-17002 - Database Error Messages

Any idea what is going on.

I had this message on different system i try to make a dev env for metabase. This is becoming my nemesis T_T

Best regards


I try the current branch master and the 0.48.x version branch with same results.

I'm not not using a proxy or a load balancer, and even if i were, running it in localhost and accessing the url localhost:3000 should not walk through a proxy or a load balancer , right ?

I try edge, chrome and firefox to rule out any extentions.

One last thing would be the antivirus then ? I have ESET, it didn't pushed any notifications about any blocage... i have admin access to my local enterprise network and tools, so if something is happenning i should be notified.

I'll double check it.

Instead of trying through an instance of metabase running with yarn dev, i tried ./bin/ to build my own uberjar (no modif on code yet) . it took more than 20 min oO .... Anyway, i launched the uberjar with java -jar metabase.jar and here i cannot even access the metabase page due to
"Refused to execute inline script because it violates the following Content Security Policy directive: "script-src 'self'"

So i am not been able to test with a "normal" instance. I'll try with the official 0.48.x release from git and add some feedback.

Best regards

Interestingly, if i run the uberjar from the official release, everything is working.
So it has to be with my env dev ....

i'm gonna close this topic and open a new one with suitable title as my problem is different now.

Thanks for all