Disable auto execution on card creation via API

Hi all,

I'm trying to migrate my queries from Redash to Metabase. Currently I'm writing a custom migration script. When I send a POST request to Metabase API in order to create cards for each redash query. The card gets executed. Is there a way to disable this feature since I'll be migrating more than 10k queries and they shouldn't be executed.

When you create a query Metabase needs to run it with a “limit 1 “ to get the metadata, so at least 1 run is needed

The solution that worked for us is to disable the Snowflake user during migration.