Docker image V0.29.3 [SOLVED]


My installation of Metabase on Azure was set up and using v0.29.3. It has now just updated to the new docker image v0.30.0. This version doesn’t seem to be working for me, and a bug has been raised.

I was wondering whether anyone has a docker image of v0.29.3 they could share with me, or explain how I can take the source code of v0.29.3 from: and turn this into a docker image of v0.29.3 which I am hoping will work until the bug is fixed.

I have installed docker, I don’t think I’m using it correctly!
(on a Windows machine) I open powershell >> go to the directory containing the unzipped source code >> type: docker build -t metabase

Many thanks for any help

So docker has this thing called tags - so if you specify that you get an exact image from here, and you have turned back the clock to almost anywhere ind the past yo want to go:

so in your case docker pull metabase/metabase:v0.29.3 or something, and you have it. As you probably already guessed :latest is a specially named default tag it runs with if you don’t specify a tag.

Read up a but on docker pull and docker run in Docker’s documentation and you’re good for now.

It’s BTW always a best practice to “pin” to a specific tag in your configuration - so your have a predictable environment.

Hope that gives you what you need?

1 Like

This version doesn’t seem to be working for me, and a bug has been raised.

@redbeard It looks like this is the issue you’re referencing (I saw you commented on it). As you already wrote there, posting some logs and any other additional details you have would be very helpful. Thanks.

Thanks @jornh - that has brought the version back to v0.29.3. I will now be ‘pinning’ my versions - I didn’t know that was a thing!

V0.29.3 came back ok - but all questions/settings/dashboards have disappeared. I’m guessing this is because v0.30 had some database migrations? I’ve rolled my PostgreSQL application db back to one from before the update. This seems to work.

Thanks again

Thanks @maz - I’ve added a bit more info

Exactly! :wink:

Sounds like the title in the first post can be marked with [SOLVED] (you can do that yourself)

Side note: @maz - nudge nudge :slight_smile: - I mentioned the Discourse solved plugin before - would be a nice addition. Would help with discoverability/usability and (you can consider a nice communty site to be part of your marketing “budget” as well)