Docker saving data that it shouldn't be?

Hi all.

Working on my first Metabase instance. Hosting on Google App Engine.

I followed the docker instructions to have it automatically connect to a postgres db.

When I logged into it for the first time, it didn't show the postgres in its database list.
It just showed H2.

I went ahead and added my Bigquery database just for the hell of it.

It showed up fine. But I thought "The second I rebuild this docker or another instance loads, this config will be lost. I better edit my Dockerfile so it connects to psql correctly"...

So I do that and confirm the new version is running. However, all my settings are still saved. The Bigquery DB is still in my DB list.

How is this possible? Does Metabase not list DB connections that are defined by environmental variables?


Hi @robs
You are misunderstanding the difference between the Metabase application database and your data sources.
The application database, which you configure with environment variables, is where Metabase stores all it's information:
Your data sources is the database you want to be able to make queries against:

Thanks for the response.

I might be misunderstanding that it's not listed in the Databases part. I'm assuming it's not?
I totally get the differences between the 2 DBs.

Is there a way to see which DB Metabase is using for application data?

I even changed the password in my psql DB, redeployed Docker and my settings are still there.
Which really confuses me. But I'm pretty new to Docker so I might just not understand what is saved on a redeploy.

Thanks again!

@robs The application database will not be added as a data source by default. It's where Metabase stores all it's information.

You define the application database that Metabase uses via environment variables.
You can see which type it uses in Admin > Troubleshooting > "Diagnostic Info".

I would very much recommend using the regular JAR if you are not used to Docker.

1 Like

The Diagnostic info is what I was looking for. Thank you!!

Yup, it's connecting to my DB correctly.