Docker setup still here even after erasing everything


I don't have a deep knowledge of docker .

I tried to reinstall my metabase setup ( from 0).

I had already ran a docker container with these:
docker run -d -p 3000:3000
-v /opt/metabase:/metabase-data
-e "MB_DB_FILE=/metabase-data/metabase.db"
-e "MB_DB_TYPE=mysql"
-e "MB_DB_DBNAME=metabase"
-e "MB_DB_PORT=3306"
-e "MB_DB_USER=metabase"
-e "MB_DB_PASS=pass"
-e "MB_DB_HOST=name of host"
-e "MB_LDAP_GROUP_BASE=cn=admins,ou=group,dc=,dc=net"
-e "MB_LDAP_HOST=ldap.
-e "MB_LDAP_PORT=389"
-e "MB_LDAP_SECURITY=starttls"
-e "MB_LDAP_USER_BASE=ou=people,dc=**,dc=net"
--name metabase metabase/metabase

I did:
docker container rm -f idof container
docker system prune -a -f
docker image rm
docker volume rm ( no volumes)

ps - aux | grep java kill java instance

find / -name metabase
and removed all related metabase databases from the host

but when i launch again with the above docker command, my users are still here and I connected metabase to its own database and it's still shows but I removed everything from the system where does it come from ?

Hi @laurameta

I would highly recommend that you perhaps consider not using Docker if you're not familiar with it.
Use the JAR instead:

Metabase stored all it's information in the application database, so in your case that would be on MySQL (MB_DB_TYPE=mysql)

If you want to delete everything Metabase knows, then delete the database metabase on MySQL and create a new empty database again, then when you start Metabase it will automatically show you the setup.


Thank you I already tried with the jar file but it seems more complicated to me to setup wth ansible.
I already deleted and recreate the mysql database but it still show my "old" logged users ... is it somewhere inside docker ? what am I missing...?

Thanks for your answer!

There must be something wrong with your setup or you are not removing the correct things.
Post "Diagnostic Info" from Admin > Troubleshooting.