Dockerized metabase just got reset and lost its data

hello. hope you are having a good day. ill jump right into the issue
our team has been using this metabase instance that was running on docker and everything was fine. till today when we tried to access it. we didn't get a response from the app. I logged onto the server and restarted the containers. and suddenly after that it asks me setup the app from 0.
i also checked our volumes and they all seem to be the old ones with our data made from a few month ago. however when i checked whats inside those volumes. our sql db seems to be intact and full but metabase_data volume is absolutly empty. is it supposed to be that way? what happend? how can i get logs on it. there is also an error i get when i run the app via docker compose but all it says is that it cannot connect to the data base and

metabase-metabase-1  | Caused by: clojure.lang.ExceptionInfo: H2 is not supported as a data warehouse {:status-code 400}

Where was your Metabase database? Was it just H2 in the same container?

as far as I'm aware of we were using a mysql database. not postgresql. so basically we neved used H2 I guess.

So where's the MySQL database? Either you were using the default H2 database or you had an external MySQL database. This is where all your dashboards, questions etc are stored, not your source data.

there was an external MySQL instance on the server. and its data seems to be intact. however the metabase needs to be setup from ground zero to connect to that. is there any logs on what happend to the app on MySQL data base? how do I set it up making sure i wont lose data?

Does the MySQL database contain the tables used by Metabase for it's own internal use? If so, using the same settings as your previous Metabase will connect to that and have all your work.

I think you're misunderstanding the databases.
You have one database that you 'report from'. That is, your own data from your application.
Then you have another database that Metabase uses for it's own settings.

I think you were using H2 without realising it (it is the default). If that's the case, you've lost your work.

If I'm wrong, get a list of the tables that are in your MySQL database.
It should contain 'Action', 'Activity', 'Audit Log', plus a load more (82 in total).

post all logs, version of Metabase, redacted env vars used...