Download xlsx file, no data

When I download the xlsx file, there is only the following information in the file, and there is no data I need


:
{“via”:[{“type”:“java.lang.InternalError”,“message”:“java.lang.reflect.InvocationTargetException”,“at”:[“sun.font.FontManagerFactory$1”,“run”,“FontManagerFactory.java”,86]},{“type”:“java.lang.reflect.InvocationTargetException”,“at”:[“jdk.internal.reflect.NativeConstructorAccessorImpl”,“newInstance0”,“NativeConstructorAccessorImpl.java”,-2]},{“type”:“java.lang.NullPointerException”,“at”:[“sun.awt.FontConfiguration”,“getVersion”,“FontConfiguration.java”,1262]}],“trace”:[[“sun.awt.FontConfiguration”,“getVersion”,“FontConfiguration.java”,1262],[“sun.awt.FontConfiguration”,“readFontConfigFile”,“FontConfiguration.java”,225],[“sun.awt.FontConfiguration”,“init”,“FontConfiguration.java”,107],[“sun.awt.X11FontManager”,“createFontConfiguration”,“X11FontManager.java”,719],[“sun.font.SunFontManager$2”,“run”,“SunFontManager.java”,367],[“java.security.AccessController”,“doPrivileged”,“AccessController.java”,-2],[“sun.font.SunFontManager”,"",“SunFontManager.java”,312],[“sun.awt.FcFontManager”,"",“FcFontManager.java”,35],[“sun.awt.X11FontManager”,"",“X11FontManager.java”,56],[“jdk.internal.reflect.NativeConstructorAccessorImpl”,“newInstance0”,“NativeConstructorAccessorImpl.java”,-2],[“jdk.internal.reflect.NativeConstructorAccessorImpl”,“newInstance”,“NativeConstructorAccessorImpl.java”,62],[“jdk.internal.reflect.DelegatingConstructorAccessorImpl”,“newInstance”,“DelegatingConstructorAccessorImpl.java”,45],[“java.lang.reflect.Constructor”,“newInstance”,“Constructor.java”,490],[“sun.font.FontManagerFactory$1”,“run”,“FontManagerFactory.java”,84],[“java.security.AccessController”,“doPrivileged”,“AccessController.java”,-2],[“sun.font.FontManagerFactory”,“getInstance”,“FontManagerFactory.java”,74],[“java.awt.Font”,“getFont2D”,“Font.java”,497],[“java.awt.Font”,“canDisplayUpTo”,“Font.java”,2250],[“java.awt.font.TextLayout”,“singleFont”,“TextLayout.java”,469],[“java.awt.font.TextLayout”,"",“TextLayout.java”,530],[“org.apache.poi.ss.util.SheetUtil”,“getDefaultCharWidth”,“SheetUtil.java”,275],[“org.apache.poi.xssf.streaming.AutoSizeColumnTracker”,"",“AutoSizeColumnTracker.java”,117],[“org.apache.poi.xssf.streaming.SXSSFSheet”,"",“SXSSFSheet.java”,82],[“org.apache.poi.xssf.streaming.SXSSFWorkbook”,“createAndRegisterSXSSFSheet”,“SXSSFWorkbook.java”,658],[“org.apache.poi.xssf.streaming.SXSSFWorkbook”,“createSheet”,“SXSSFWorkbook.java”,679],[“org.apache.poi.xssf.streaming.SXSSFWorkbook”,“createSheet”,“SXSSFWorkbook.java”,90],[“dk.ative.docjure.spreadsheet$add_sheet_BANG_”,“invokeStatic”,“spreadsheet.clj”,283],[“dk.ative.docjure.spreadsheet$add_sheet_BANG_”,“invoke”,“spreadsheet.clj”,279],[“metabase.query_processor.streaming.xlsx$fn__34064”,“invokeStatic”,“xlsx.clj”,39],[“metabase.query_processor.streaming.xlsx$fn__34064”,“invoke”,“xlsx.clj”,36],[“clojure.lang.MultiFn”,“invoke”,“MultiFn.java”,234],[“metabase.query_processor.streaming$streaming_context”,“invokeStatic”,“streaming.clj”,53],[“metabase.query_processor.streaming$streaming_context”,“invoke”,“streaming.clj”,46],[“metabase.query_processor.streaming$streaming_context”,“invokeStatic”,“streaming.clj”,58],[“metabase.query_processor.streaming$streaming_context”,“invoke”,“streaming.clj”,46],[“metabase.query_processor.streaming$streaming_response_STAR_$fn__34128$fn__34129”,“invoke”,“streaming.clj”,73],[“metabase.query_processor.streaming$streaming_response_STAR_$fn__34128”,“invoke”,“streaming.clj”,72],[“metabase.async.streaming_response$do_f_STAR_”,“invokeStatic”,“streaming_response.clj”,66],[“metabase.async.streaming_response$do_f_STAR_”,“invoke”,“streaming_response.clj”,64],[“metabase.async.streaming_response$do_f_async$fn__23118”,“invoke”,“streaming_response.clj”,85],[“clojure.lang.AFn”,“applyToHelper”,“AFn.java”,152],[“clojure.lang.AFn”,“applyTo”,“AFn.java”,144],[“clojure.core$apply”,“invokeStatic”,“core.clj”,665],[“clojure.core$with_bindings_STAR_”,“invokeStatic”,“core.clj”,1973],[“clojure.core$with_bindings_STAR_”,“doInvoke”,“core.clj”,1973],[“clojure.lang.RestFn”,“invoke”,“RestFn.java”,425],[“clojure.lang.AFn”,“applyToHelper”,“AFn.java”,156],[“clojure.lang.RestFn”,“applyTo”,“RestFn.java”,132],[“clojure.core$apply”,“invokeStatic”,“core.clj”,669],[“clojure.core$bound_fn_STAR_$fn__5749”,“doInvoke”,“core.clj”,2003],[“clojure.lang.RestFn”,“invoke”,“RestFn.java”,397],[“clojure.lang.AFn”,“run”,“AFn.java”,22],[“java.util.concurrent.Executors$RunnableAdapter”,“call”,“Executors.java”,515],[“java.util.concurrent.FutureTask”,“run”,“FutureTask.java”,264],[“java.util.concurrent.ThreadPoolExecutor”,“runWorker”,“ThreadPoolExecutor.java”,1128],[“java.util.concurrent.ThreadPoolExecutor$Worker”,“run”,“ThreadPoolExecutor.java”,628],[“java.lang.Thread”,“run”,“Thread.java”,834]],"_status":500}

{
“browser-info”: {
“language”: “zh-CN”,
“platform”: “Win32”,
“userAgent”: “Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/83.0.4103.106 Safari/537.36”,
“vendor”: “Google Inc.”
},
“system-info”: {
“file.encoding”: “UTF-8”,
“java.runtime.name”: “OpenJDK Runtime Environment”,
“java.runtime.version”: “11.0.7+10”,
“java.vendor”: “AdoptOpenJDK”,
“java.vendor.url”: “https://adoptopenjdk.net/”,
“java.version”: “11.0.7”,
“java.vm.name”: “OpenJDK 64-Bit Server VM”,
“java.vm.version”: “11.0.7+10”,
“os.name”: “Linux”,
“os.version”: “3.10.0-957.el7.x86_64”,
“user.language”: “en”,
“user.timezone”: “Asia/Shanghai”
},
“metabase-info”: {
“databases”: [
“h2”,
“mysql”,
“sparksql”,
“presto”
],
“hosting-env”: “unknown”,
“application-database”: “h2”,
“application-database-details”: {
“database”: {
“name”: “H2”,
“version”: “1.4.197 (2018-03-18)”
},
“jdbc-driver”: {
“name”: “H2 JDBC Driver”,
“version”: “1.4.197 (2018-03-18)”
}
},
“run-mode”: “prod”,
“version”: {
“date”: “2020-05-28”,
“tag”: “v0.35.4”,
“branch”: “release-0.35.x”,
“hash”: “b3080fa”
},
“settings”: {
“report-timezone”: null
}
}
}

Hi @rayn
My first guess is that it has something to do with the Java version or included libraries.

Make sure that you are not using a headless version of Java. The full version of AdoptOpenJDK is recommended:
https://adoptopenjdk.net/releases.html?variant=openjdk11&jvmVariant=hotspot
Alternatively try OpenJDK8.

If you’re using Centos, then you might need to install xmanager:
Exception in thread "main" java.awt.AWTError: Can't connect to X11 window server using 'localhost:10.0' as the value of the DISPLAY variable

Can you try the Docker version of Metabase?

And you should migrate away from H2, when using Metabase in production:
https://www.metabase.com/docs/latest/operations-guide/migrating-from-h2.html

This metabase is for testing. I modified it to jdk8 to solve this problem. Thank you