Elastic beanstalk app rebuild fail -> RDS restore 'backend' seems to work but can't acces http interface. any aws pro's want to freelance support?


I was having problems with the latest metabase release on Elastic Beanstalk so I hit rebuild environment. I didn’t realize this would change the RDS. Luckily the snapshot was backup.

I’ve been trying to restore to the old RDS backend database and can’t figure it out. I did get one of the environments i’ve been trying to kind of work - I received pulses. But i can’t access the http front end from these attempts. I think it might be an SSL problem. Ive tried removing NGINX_FORCE_SSL, going to single instance no load balancer, adding a new ssl cert. I can’t figure it out.

If someone has some other steps I can try to restore that’d be great.

But - not sure if this is appropriate to ask here? - if you are an AWS pro (or able to get us back up) we would love to pay for this support. Just give you the login perms you need to fix.

You can reach me here dillon 4degre.es

Is your RDS instance separate from ElasticBeanstalk deployment (i.e. you connect to it by setting environment variables in Configuration>Sofrtware)? If it is, then it shouldn’t have been affected by the rebuild.

It was not a separate RDS unfortunately :frowning: lesson learned there.

Though I did have it set to create a snapshot on rebuild/termination.

I know there is a correct snapshot - it is working to send Pulses. But I just can’t get the front end to go up.

If you have any other ideas I should try - I tried to list what I’ve tried so far but definitely could not have enough detail or knowledge here.

Or if you think you can fix it we would love to pay!

I just wanted to share how King_edward was (THANK YOU) able to get this back up! I’ll going to add some keywords at the bottom too hopefully it would help anyone else find these steps that worked for us in the future.

  • Go to RDS snapshots -> action -> restore snapshot
    • postgres. a small version. in our version password since this was how it was originally setup
  • Once the database is created and live click it -> modify. In our case change password since I didn’t know it. Take note of network security group
  • Go to elastic beanstalk
    • create a new environment/app using the zip file upload
    • go through the normal configuration options
    • under software put in the following key values:
      • MB_DB_DBNAME (this is not the longer name identifier, i was able to find in the live RDS config summary - it was a four letter string)
      • MB_DB_HOST the host url of the RDS
      • MB_DB_PASS the password you wrote down
      • MB_DB_PORT the RDS port ours was 5432
      • MB_DB_TYPE postgres
      • MB_DB_USER the user you wrote down
    • for us in the security group needed to add the same one from RDS is added
    • we also had a launch problem with near 100% cpu on the tiniest ec2 instance size, changed to small which seemed to work
    • in our version there is no database under the elastic beanstalk database setting. because we manually created a separate RDS and put those settings as key value s

I think I got all the main things that got us back up!

here are some search keywords: How to restore metabase aws elatsic beanstalk from rds relationshional database store snapshot backup rebuilt environment connection error elasticbeanstalk rebuilt rebuild error lost data

1 Like