Email issue - Sorry, something went wrong. Please try again

I’ve tried both gmail and mandrill and both give this error message: Sorry, something went wrong. Please try again. when I try a test send from the admin settings > email page.

I’ve tried many different things including the Gmail relay method with no luck.

We are running metabase off a local server here in the office, which is also connected to the internet. We used the Metabase.jar file method to install Metabase.

Hope someone can point me in the right direction.

Can you check the server logs for any errors?

We could not find any server logs related to this issue. Perhaps there is somewhere specific you could suggest looking?

The metabase jar outputs the following when you attempt to send a test email:

WARN :: Failed to send email: ServerName: ServerName: unknown error
WARN :: Problem connecting to mail server: ServerName: ServerName: unknown error
ERROR metabase.middleware :: POST /api/email/test 500 (713 ms) {:message “Sorry, something went wrong. Please try again.”}

No matter what service is tried it produces the same issue.

Those are the server logs.

Can you verify the smtp credentials using a mail program of some kind of make sure they actually work? Is it possible some fields were empty?


Thanks for the response. I installed a phpmailer script on the same server and was able to successfully send emails using the same mandrill connection details as metabase:
port 587
username / API password
I have rechecked all these credentials in metabase but we are still getting the same error listed above.

Just to ask one more dumb question, but you’re using a paid mailchimp plan connected to your mandrill account? They recently shut off their free tiers.

Baring that, is there any information in the “send test” form? We might need to get you a special build with better error handling, as we can’t reproduce it on our end.

Yeah we have a paid account with mailchimp that is connected to the mandrill account.

Unfortunately there is no extra information regarding the error that hasn’t already been posted in this thread.

Is there any possibility of an update on this issue? We are keen to solve the problem so a more bespoke build for better error handling sounds promising. Thanks.

One last thing to check, @agilliland mentioned that we were using SSL on port 465 internally.

Can you see if that setting works with your credentials.

I’m having the same problem with Mailgun SMTP. Tried all SSL/TLS combinations with ports 465, 587. Getting this in the logs:

Nov 18 20:57:24 WARN :: Problem connecting to mail server: 
Nov 18 20:57:24 ERROR metabase.middleware :: PUT /api/email 500 (1 s) (0 DB calls)
{:message "Sorry, something went wrong. Please try again."}

Any ideas?

Can you try your creds on an email client or something else? More often than not, that’s the root cause.

Ran a test with TLS and authed successfully:

$ openssl s_client -connect -starttls smtp


334 VXNlcm5hbWU6
334 UGFzc3dvcmQ6
235 2.0.0 OK

I switched from Mailgun to Amazon SES SMTP and it’s working now. For some reason it doesn’t fly with mailgun (or maybe it was related to a VPC config somehow, but everything was wide open for debugging purposes). At any rate, all good now, thanks!