Email Sending Error

Hi,

I have several emails alerts setup but some do not send. I have found the error below in the logs.

Metabase 0.33.4

Thanks,

[6a3f2b8e-45bd-43bf-86cc-95cb5235e4c1] 2019-10-30T07:00:02+11:00 WARN metabase.email Failed to send email
[6a3f2b8e-45bd-43bf-86cc-95cb5235e4c1] 2019-10-30T07:00:02+11:00 ERROR metabase.query-processor.middleware.results-metadata Error recording results metadata for query:
clojure.lang.ExceptionInfo Input to infer-special-type does not match schema:

[(named {:name (not (“Non-blank string” “”))} field-or-column)]

("–> sync.analyze.classifiers.name$fn__42121$infer_special_type__42126.invoke(name.clj:139)"
“sync.analyze.query_results$fn__44220$maybe_infer_special_type__44225$fn__44226$fn__44227.invoke(query_results.clj:50)”
“sync.analyze.query_results$fn__44220$maybe_infer_special_type__44225$fn__44226.invoke(query_results.clj:43)”
“sync.analyze.query_results$fn__44220$maybe_infer_special_type__44225.invoke(query_results.clj:39)”
“sync.analyze.query_results$results__GT_column_metadata$iter__44291__44295$fn__44296.invoke(query_results.clj:87)”
“sync.analyze.query_results$add_insights$iter__44264__44268$fn__44269.invoke(query_results.clj:65)”
“sync.analyze.query_results$add_insights.invokeStatic(query_results.clj:65)”
“sync.analyze.query_results$add_insights.invoke(query_results.clj:60)”
“sync.analyze.query_results$results__GT_column_metadata.invokeStatic(query_results.clj:88)”
“sync.analyze.query_results$results__GT_column_metadata.invoke(query_results.clj:81)”
“query_processor.middleware.results_metadata$record_and_return_metadata_BANG_$fn__44316.invoke(results_metadata.clj:91)”
“query_processor.middleware.format_rows$format_rows$fn__38510.invoke(format_rows.clj:26)”
“query_processor.middleware.add_dimension_projections$add_remapping$fn__34938.invoke(add_dimension_projections.clj:232)”
“query_processor.middleware.add_source_metadata$add_source_metadata_for_source_queries$fn__35638.invoke(add_source_metadata.clj:107)”
“query_processor.middleware.resolve_source_table$resolve_source_tables$fn__41607.invoke(resolve_source_table.clj:46)”
“query_processor.middleware.add_row_count_and_status$add_row_count_and_status$fn__35498.invoke(add_row_count_and_status.clj:16)”
“query_processor.middleware.driver_specific$process_query_in_context$fn__37521.invoke(driver_specific.clj:12)”
“query_processor.middleware.resolve_driver$resolve_driver$fn__41221.invoke(resolve_driver.clj:22)”
“query_processor.middleware.bind_effective_timezone$bind_effective_timezone$fn__36835$fn__36836.invoke(bind_effective_timezone.clj:9)”
“util.date$call_with_effective_timezone.invokeStatic(date.clj:88)”
“util.date$call_with_effective_timezone.invoke(date.clj:77)”
“query_processor.middleware.bind_effective_timezone$bind_effective_timezone$fn__36835.invoke(bind_effective_timezone.clj:8)”
“query_processor.middleware.store$initialize_store$fn__44341$fn__44342.invoke(store.clj:11)”
“query_processor.store$do_with_store.invokeStatic(store.clj:46)”
“query_processor.store$do_with_store.invoke(store.clj:40)”
“query_processor.middleware.store$initialize_store$fn__44341.invoke(store.clj:10)”
“query_processor.middleware.async$async__GT_sync$fn__20798.invoke(async.clj:23)”
“query_processor.middleware.async_wait$runnable$fn__36561.invoke(async_wait.clj:89)”)

Hi @advancedservers
Currently the email logging is … bad, but there’s work being done to give more details.
Do you have access to the mail server? What do you see in the log there?
My first guess is either incorrect security settings (none vs SSL vs TLS) or some antivirus/firewall is messing with the connection between Metabase and the mail server.