Email with G Suite and Amazon SES

I initially setup my Metabase email account using a new Google Suite account I created for this usage.
Everything worked fine at first and I was able to send 2 invitations to my coworkers. They received the email and joined as expected, that was last week.

Today, I invited another teammate and he didn’t get the email, after a while, I figured the “test email” feature wouldn’t work and the whole email settings was broken. (It would be nice to get warned somehow, like displaying a message in the admin console)

And… I couldn’t fix it so far. I don’t know what happened, but somehow it now considers Metabase as a “Less secure apps”, I got warning emails about it. Basically Google blocked connexion attempts.

I tried to allow “Less secure apps” but couldn’t, something likely related to the fact we’re using a low G Suite plan. (as far as I understood…)
I also tried to create a App password, but ran into the same issue (low plan).

So, I saw https://www.metabase.com/docs/v0.28.6/administration-guide/02-setting-up-email.html proposed Amazon SES. I wasn’t using SES yet so I had to configure it and my tests work now (from SES), but when I try to use the SMTP login/password at https://metabase.studylink.fr/admin/settings/email, it fails.

I’m unsure what protocol I should use but TLS seems to be the one to go, I tried STARTTLS as well but it failed too. (in the screenshot, I used the IAM account as SMTP username, but I also tried with the actual SMTP username and it doesn’t work any better)

I don’t understand why it’s failing with the SES account since I configured the SES domain.

Do you have any advices regarding this issue? Thanks.

It looks like you are mixing credentials for SES with the gmail smtp server name. That’s probably not a good idea :wink: try with the smtp hostname for SES.

I think the error message originating from the Google smtp server is actually pretty good in this case.

1 Like

Thanks! It was so obvious I had completely missed it, it didn’t occur to me I also had to change the SMTP host.

For the record, AWS SES SMTP host is email-smtp.us-east-1.amazonaws.com if the SES is configured in us-east-1.

Source: https://docs.aws.amazon.com/ses/latest/DeveloperGuide/send-an-email-using-smtp.html

1 Like