Error building questions with Oracle Database

Good Morning,
I am using an Oracle database and when asking a simple question with Filter … but I have this (error attached). Would anyone know the reason and how to solve?

Metabase version is v0.33.5

Hi @Lourival
I don’t know why Oracle is so strict - or if it has something to do with Metabase’s implementation, but you need to add the schema too, so:

select * from GNAE.TB_PRO_PROCESSO
WHERE {{situacao}}

Ok @flamber, the schema quoting issue worked here.

Now, in this other attachment, I set the filter, but it didn’t show up, why is it? If I change the “variable type” to anything other than “Field Filter”, the error is different (see attachment “Metabase_Error_porque_desse_erro.png”)
Would you help me ???
Obs.: It is also an Oracle database

Anexo01

Anexo02

@Lourival Notice the “Tipo de filtro” is set to “None” - and read the notice below. You need to setup your Data Model to be able to use Field Filters.

Hi @flamber, thanks so much for your guidance, however, I have not found where to do this setting (enable the filter or not) and I don’t know how to do it. Could you help me but this time?

@Lourival
You need to set the Field Type in Admin > Data Model > (db) > (table) > (column) :gear:
The type has to be one of the following from the list, as defined in the documentation:
https://www.metabase.com/docs/latest/users-guide/13-sql-parameters.html#the-field-filter-variable-type

@flamber, Metabase surprises me every time a question arises. I’m even thinking of writing an article about this tool. Very spectacular indeed.
Thanks huh!

Hi @flamber,
About enabling the filter in the field, I’ve tried here as the attachment, but even checking the options, when I choose the field that I configured the filter, it only shows the option “none”. What do I need to do to work here?

@Lourival You have not set the “Tipo de Campo” - it needs to be one of the types as listed in the documentation.

@flamber, you know a lot!

It worked here, thank you very much.
Note: If one day you come to Brazil, I will buy you a beer and prepare a barbecue.

Hug,

1 Like