Error conection between Metabase and Databricks

Hi guys,

Before the update, the connection didn’t work anymore and I don’t know why.

When I tryied to show our data in the table, I got the error message:
“Connections could not be acquired from the underlying database!”

And this error message is when I tryied to save the connection, in the administrator panel:
“[Simba]SparkJDBCDriver Error setting/closing session: Open Session Error.”

Anyone can help me with this?

Thanks.

Even I face the same Issue, below are the details:

I have followed the link https://github.com/ifood/metabase-sparksql-databricks-driver and downloaded the jar sparksql-databricks.metabase-driver.jar and placed in …/plugins/ directory .

The metabase version we are using is v0.33.1 and unfortunately the we were not able to establish connection.When all the fields are filled and I clicked on save,Below is the error message:

[Simba]SparkJDBCDriver Error setting/closing session: Open Session Error

To resolve above error we have downloaded the simba custom jar SparkJDBC41.jar and placed in /home/ubuntu/apps/metabase/plugins but no luck the error remains same.

Please let me know is there a way I can resolve this

Have a look in this topic - it has more details: Connecting Databricks Spark to Metabase

@flamber Thank you so much, yes please follow below link.