Error in migrating to Postgres from H2

I am trying to Migrate from H2 to postgres. both the matebase are of same version 0.31.2
the migration is failing due to – relation “public.databasechangeloglock” does not exist at character 22

full flow:

  1. Stopping the old metabase and taking the dump of old db in local

  2. Running the container of postgres
    docker run --rm --name pg-docker
    -v $HOME/MetabaseDocker-V2/newDocker/data/new:/var/lib/postgresql/data
    -e POSTGRES_USER=postgres
    -e POSTGRES_DB=postgres
    -d -p 5432:5432 postgres

  3. Running the Metabase container
    docker run -p 3000:3000 --name metabase
    -v /Users/dshadab/MetabaseDocker-V2/newDocker/metabase-data:/metabase-data
    -e MB_DB_FILE=/metabase-data/metabase.db
    -e MB_DB_TYPE=postgres
    -e MB_DB_PORT=5432
    -e MB_DB_USER=postgres
    -e MB_DB_PASS=docker
    -e MB_DB_DBNAME=postgres
    -e MB_DB_HOST=
    -e “JAVA_TOOL_OPTIONS=-Xmx4g”
    -e MB_DB_AUTOMIGRATE=false
    metabase/metabase load-from-h2

snapshot from metabase log:
Picked up JAVA_TOOL_OPTIONS: -Xmx4g
03-14 18:21:21 INFO metabase.util :: Loading Metabase…
03-14 18:21:21 INFO metabase.util :: Maximum memory available to JVM: 3.6 GB
03-14 18:21:28 INFO util.encryption :: Saved credentials encryption is DISABLED for this Metabase instance. :unlock:
For more information, see
03-14 18:21:40 INFO metabase.db :: Verifying postgres Database Connection …
03-14 18:21:40 INFO metabase.db :: Verify Database Connection … :white_check_mark:
03-14 18:21:40 INFO metabase.db :: Running Database Migrations…
03-14 18:21:40 INFO metabase.db :: Setting up Liquibase…
03-14 18:21:41 INFO metabase.db :: Liquibase is ready.
03-14 18:21:41 INFO metabase.db :: Checking if Database has unrun migrations…
03-14 18:21:43 INFO metabase.db :: Database has unrun migrations. Waiting for migration lock to be cleared…
03-14 18:21:43 INFO metabase.db :: Migration lock is cleared. Running migrations…
03-14 18:21:47 INFO metabase.db :: Database Migrations Current … :white_check_mark:
Temporarily disabling DB constraints…
Transfering 1 instances of Database…[OK]
Transfering 8 instances of User…[OK]
Transfering 19 instances of Setting…[OK]
Transfering 80 instances of Dependency…[OK]
Transfering 21 instances of Table…[OK]
Transfering 1271 instances of Field…[OK]
Transfering 467 instances of FieldValues…[OK]
Transfering 12 instances of Segment…[OK]
Transfering 46 instances of Metric…[OK]
Transfering 618 instances of Revision…[OK]
Transfering 850 instances of ViewLog…[OK]
Transfering 157 instances of Session…[OK]
Transfering 2 instances of Dashboard…[OK]
Transfering 258 instances of Card…[OK]
Transfering 2 instances of DashboardCard…[OK]
Transfering 629 instances of Activity…[OK]
Transfering 5 instances of Pulse…[OK]
Transfering 26 instances of PulseCard…[OK]
Transfering 5 instances of PulseChannel…[OK]
Transfering 13 instances of PulseChannelRecipient…[OK]
Transfering 3 instances of PermissionsGroup…[OK]
Transfering 13 instances of PermissionsGroupMembership…[OK]
Transfering 43 instances of Permissions…[OK]
Transfering 27 instances of Collection…[OK]
Transfering 3371 instances of TaskHistory…[OK]
Transfering 14 instances of DataMigrations…[OK]
Setting postgres sequence ids to proper values…

SnapShot from postgres Log
The files belonging to this database system will be owned by user “postgres”.
This user must also own the server process.

The database cluster will be initialized with locale “en_US.utf8”.
The default database encoding has accordingly been set to “UTF8”.
The default text search configuration will be set to “english”.

Data page checksums are disabled.

fixing permissions on existing directory /var/lib/postgresql/data … ok
creating subdirectories … ok
selecting default max_connections … 100
selecting default shared_buffers … 128MB
selecting dynamic shared memory implementation … posix
creating configuration files … ok
running bootstrap script … ok
performing post-bootstrap initialization … ok
syncing data to disk … ok

WARNING: enabling “trust” authentication for local connections
You can change this by editing pg_hba.conf or using the option -A, or
–auth-local and --auth-host, the next time you run initdb.

Success. You can now start the database server using:

pg_ctl -D /var/lib/postgresql/data -l logfile start

waiting for server to start…2019-03-14 19:54:02.964 UTC [41] LOG: listening on Unix socket “/var/run/postgresql/.s.PGSQL.5432”
2019-03-14 19:54:03.038 UTC [42] LOG: database system was shut down at 2019-03-14 19:53:59 UTC
2019-03-14 19:54:03.069 UTC [41] LOG: database system is ready to accept connections
server started

/usr/local/bin/ ignoring /docker-entrypoint-initdb.d/*

2019-03-14 19:54:03.147 UTC [41] LOG: received fast shutdown request
waiting for server to shut down…2019-03-14 19:54:03.150 UTC [41] LOG: aborting any active transactions
2019-03-14 19:54:03.152 UTC [41] LOG: background worker “logical replication launcher” (PID 48) exited with exit code 1
2019-03-14 19:54:03.156 UTC [43] LOG: shutting down
.2019-03-14 19:54:03.200 UTC [41] LOG: database system is shut down
server stopped

PostgreSQL init process complete; ready for start up.

2019-03-14 19:54:03.287 UTC [1] LOG: listening on IPv4 address “”, port 5432
2019-03-14 19:54:03.287 UTC [1] LOG: listening on IPv6 address “::”, port 5432
2019-03-14 19:54:03.293 UTC [1] LOG: listening on Unix socket “/var/run/postgresql/.s.PGSQL.5432”
2019-03-14 19:54:03.366 UTC [50] LOG: database system was shut down at 2019-03-14 19:54:03 UTC
2019-03-14 19:54:03.394 UTC [1] LOG: database system is ready to accept connections
2019-03-14 19:54:56.209 UTC [58] ERROR: relation “public.databasechangeloglock” does not exist at character 22
2019-03-14 19:54:56.209 UTC [58] STATEMENT: SELECT COUNT(*) FROM public.databasechangeloglock

Please and please suggest.