Error: Invalid output: ["distinct"]

One of my tables in Metabase has been giving this error when attempting to access or use the data: Invalid output: ["distinct"]

Only when I attempt to count all rows does it gives the correct response (simple row count result). Any attempt to access the actual data results in the error. Nothing has changed to the actual data since it was working in the past. We are currently using Metabase 0.48.0

Also, if I try to access my data directly outside of Metabase it works perfectly. We are using Amazon Athena for this tables data source. I have refreshed the table and there is no use of distinct in the view definition.

1 Like

Getting the same error after the recent update
Running Metabase version 0.48.0,
data source is MySQL hosted on Amazon RDS.

The issue is impacting only certain tables from the data source, But this is only when you use visual editor or explore the table in GUI,
Native SQL query on the same table works fine.

@Chirag Is this error still happening for you? I am still experiencing it on my end.

please post the entire log

Yes, still the same, I think it's a version thing, started happening after update to 0.48.0

It's fixed for me now, updated to release 0.48.1

1 Like