Error on drilldown: Table is not present in the Query Processor Store

Hi all,

I’m getting a strange error when I try drill-down (I think that’s the term) through a foreign key. Here’s what I did specifically:

  • I have a table called Customer and a table called Property.

  • In Admin, I defined a foreign key relationship from Customer to Property. The field used is a UUID, if that matters.

  • I used “Ask a question” to make a table view of the Customer table (no custom SQL).

  • In that view, the Property UUID is shown as a link. When I click that link and select “View details” I get the following error:

    Error: Table 2,891 is not present in the Query Processor Store.

I can attest that there is no table in my DB named “2,891” :slight_smile:

Any idea what’s going on here? I should probably mention that I’m using 0.33.2.

Thanks in advance for the help!
Joe

Hi @JZee
Which database are you querying?
I’m sure I’m doing something wrong, when I try to reproduce with Sample Dataset, but I don’t understand what you’re doing in the third step.

Hi @flamber,

Thanks for looking into this. Playing with it a little more, I have a new piece of data to share. It’s related to dashboards, it seems. Here’s what I tried:

:white_check_mark: Navigate to table by clicking on the datasource then selecting the table in question: Drill-through works.

:white_check_mark: View table by clicking “Ask a question” --> “Simple Question” then choosing the table in question: Drill-through works. I tried adding a bunch of filters, etc… it always works.

:x: Save the above question. Add that question to a dashboard. Load the dashboard and try clicking the drill-through from the dashboard. This is when I get the error saying “Error: Table 2,891 is not present in the Query Processor Store.”

More data: The dashboard scenario above works if there are no filters. When I add a date filter to the whole dashboard, this is when I get the error. I have reproduced on the sample DB by saving a question pointing to the Orders table, adding it to a new dashboard, then adding a date filter (pointed to “created at”) to the dashboard.

@JZee
Can you post the step-by-step to reproduce on sample dataset? I’m fairly sure you’re seeing an existing issue, but without seeing the error log or browser console, then it’s difficult to know.

Here you go:

Step 1: Ask a question on Orders

Step 2: Save the question
image

Step 3: When it asks if you want to add the question to a dashboard, say yes
image

Step 4: Select "+ Create new dashboard"

Step 5: Name the dashboard
image

Step 6: Add a date filter and save

Step 7: Click on a Product ID --> View details

Step 8: See error

@JZee
Awesome! I misunderstood you in the beginning. I thought you were using a Saved Question, which has some known issues.
Looks like you’re seeing this issue - I’ve added comment with your steps:
https://github.com/metabase/metabase/issues/8055