ERROR: operator does not exist

I'm getting this error on a signed embed:

ERROR: operator does not exist: integer = character varying Hint: No operator matches the given name and argument types. You might need to add explicit type casts. Position: 81

I checked github and saw there is an issue related to this message, but I couldn't understand how it applies to me.

I'm using a sqlite database and the public version of the dashboard works perfectly:

Not quite sure what was happened because at first it was working fine, until I tried to add a date filter.
To fix it, I reverted to a version without filters, but the issue persists.

In case it's relevant, this data comes from two tables and I'm saving the signed urls in a json file.

so far this looks like it's related to inconsistent timestamp data, I'm trying to resolve it.
update: fixed the timestamp but the problem still occurs.

@brunoamaral SQLite is different from other databases, and for some reason it allows mixed timestamps in the same column, which is just extremely confusing.

But you'll need to include "Diagnostic Info" from Admin > Troubleshooting, and the full stacktrace from Admin > Troubleshooting > Logs.
The error looks like it's coming from Postgres, not SQLite, which indicates that the problem is elsewhere.

Sqlite has a lot of flaws and I barely worked with databases before this project, so the problem may be on my side. :slightly_smiling_face:

The logs are here:

@brunoamaral You're generating a dashboard ID string instead of integer:

  "resource": {
    "dashboard": "2"
  "params": {},
  "exp": 1639342874
1 Like