Error when I try to explore data without any filters

There's a table in PostgreSQL database with jsonb columns in it. It works fine when I perform Native query in Metabase, but I get error when I explore this table from the main page (Our data - Select database - Select table)

ERROR: invalid input syntax for type bigint: "{"price": 950, "address": null}"

There's another table with similar structure with the same error

ERROR: invalid input syntax for type bigint: "{"price": 0}"

I tried some other tables with different jsons, but it seems to work there, so I guess Metabase can't parse a particular row.

Diagnostic info

  "browser-info": {
    "language": "en-NZ",
    "platform": "Linux x86_64",
    "userAgent": "Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/ Safari/537.36",
    "vendor": "Google Inc."
  "system-info": {
    "file.encoding": "UTF-8",
    "": "OpenJDK Runtime Environment",
    "java.runtime.version": "11.0.11+9-Ubuntu-0ubuntu2.20.04",
    "java.vendor": "Ubuntu",
    "java.vendor.url": "",
    "java.version": "11.0.11",
    "": "OpenJDK 64-Bit Server VM",
    "java.vm.version": "11.0.11+9-Ubuntu-0ubuntu2.20.04",
    "": "Linux",
    "os.version": "5.4.0-42-generic",
    "user.language": "en",
    "user.timezone": "Etc/UTC"
  "metabase-info": {
    "databases": [
    "hosting-env": "unknown",
    "application-database": "postgres",
    "application-database-details": {
      "database": {
        "name": "PostgreSQL",
        "version": "12.4"
      "jdbc-driver": {
        "name": "PostgreSQL JDBC Driver",
        "version": "42.5.0"
    "run-mode": "prod",
    "version": {
      "date": "2022-10-17",
      "tag": "v0.44.5",
      "branch": "release-x.44.x",
      "hash": "29fab4d"
    "settings": {
      "report-timezone": "Europe/Warsaw"

Hi @lesescaldes
Something is indicating that you have a nested JSON structure, which is not matching for all rows.
Sounds like - upvote by clicking :+1: on the first post

1 Like