Fatal Error: The Metabase server terminated unexpectedly

I’m running the latest version of Metabase (Metabase 0.17.0.5). When I installed the update Metabase stopped opening properly and is crashing. I’m unable to get past the loading screen when you first open the app so I can’t change any settings. Eventually after it doesn’t move past the loading screen I’m getting the error message “Fatal Error: The Metabase server terminated unexpectedly”.

I’ve tried restarting & re-installing Metabase but am getting the same problem.

Does anyone know what might be going on? Any help here would be appreciated.

Thank you!!

Is this the Mac app?

Can you open up the Console app (command+space, then type console to get to it) and see if there’s any information.

Yep this is the mac app. Just installed the new update and am still having the same problem.

When I open up the Console app I’m just seeing a lot of messages from Metabase saying “We’ve been waiting X amount of seconds, what’s going on?”, but no other information:

Any idea how to fix this?

Thank you!

Hey @bchester - did you find a solution to this? Running into the same problem.

Sorry to have not followed up on this. What’s at the top of your logs?

I.e. what was the last line before the we've been waiting X seconds?

Here are the full logs right before that message:

If i go to ~/Library/Application Support/Metabase and delete the metabase.db.h2.db file, I don’t see the error but it loses my entire user profile.

It looks like the index file of the embedded application database got corrupted. Haven’t seen that before. Did your computer itself crash recently?

Nope, computer hasn’t crashed and all other apps have been running fine

I’m having the same issues. I hadn’t used metabase for a couple of months, then when I launched it I got the error. Reinstallation does not fix the issue.

Which version of MB are you running? Are you getting the same “Can’t connect to H2” message in the console?

Still having the same issue and have been unable to get on for the past few months now… tried reinstalling numerous times and have ben keeping current with all the Metabase updates.

Just upgraded to macOS Sierra and still having the same problem.

Has anyone figured out a fix?

Any progress on this? I tried all the steps above, but nothing helped. @sameer Just before the “Waited X seconds”, I’m getting a “15/10/16 2:04:47.027 PM Metabase[6862]: INFO metabase.db :: Verifying h2 Database Connection …” message.

I’m getting the same error as well on the latest version of the Mac app (0.20.1). It makes Metabase unusable after setting up dashboards, etc. Is there any update on when this will be fixed? Would rolling back to an old version, say 0.16.1, be a temporary fix?

The issue is that some setting in ~/Library/Application Support/Metabase doesn’t work well with the app and causes termination on startup. I’ve been able to delete the files in that directory, but as stated above, lose all of my past progress.

Would this be avoided if I set this up on ec2 or something? We had tried several weeks ago and it resulted in crashes as well, but we didn’t try the latest versions. Just looking for a fix so I can start using this amazing product!