Fatal error, The Metabase server terminated unexpectedly

Hi there,

I know this issue has been addressed before but nothing since dec’17 so I open a new bug report about it.
I have been unable to use launch Metabase (mac app) since this morning. I tried with the latest update (0.31) and the previous one, same result. I am on macOS Mojave v10.14.1.

I cannot copy & paste the entire error message but here is the beginning of it:

> The Metabase server terminated unexpectedly.

Messages:
INFO metabase.core :: Démarrage de Metabase en mode AUTONOME
INFO metabase.core :: Lancement du serveur web Jetty intégré avec la configuration :
{:port 13245}
INFO metabase.core :: Démarrage de Metabase version v0.31.0 (adf9a89 release-0.31.0)…
INFO metabase.core :: Le fuseau horaire du système est “Europe/Paris”…
WARNING: any? already refers to: #'clojure.core/any? in namespace: monger.collection, being replaced by: #'monger.collection/any?
INFO metabase.core :: Configuration et migration de la base de données Metabase. Faites sil vous plaît preuve de patience, cela peut prendre une minute…
INFO metabase.db :: Vérification de la connexion à la base de données h2…
ERROR metabase.driver :: Echec de connexion à la base de données : org.h2.jdbc.JdbcSQLException: La base de données est peut-être en cours dutilisation: {0}. Solutions posibles: fermer toutes les autres connexions; utilisez le mode serveur
Database may be already in use: {0}. Possible solutions: close all other connection(s); use the server mode [90020-197]
ERROR metabase.core :: LInitialisation de Metabase a ECHOUE
java.lang.AssertionError: Assert failed: Unable to connect to Metabase h2 DB.
(binding [allow-potentailly-unsafe-connections true] (require (quote metabase.driver)) ((resolve (quote metabase.driver/can-connect-with-details?)) engine details))
at metabase.db$verify_db_connection.invokeStatic(db.clj:390)
at metabase.db$verify_db_connection.invoke(db.clj:383)
at metabase.db$verify_db_connection.invokeStatic(db.clj:386)
at metabase.db$verify_db_connection.invoke(db.clj:383)
at metabase.db$setup_db_BANG_.invokeStatic(db.clj:452)
at metabase.db$setup_db_BANG_.doInvoke(db.clj:446)
at clojure.lang.RestFn.invoke(RestFn.java:421)
at metabase.core$init_BANG_.invokeStatic(core.clj:162)
at metabase.core$init_BANG_.invoke(core.clj:139)
at metabase.core$start_normally.invokeStatic(core.clj:

Thank for your help

Could you already have a copy running? Try a reboot to see if that clears the connection being in use.

Thank you Andrew, it actually worked!

“Keep It Simple, stupid” even for bugs… I guess :wink: I uninstalled and looked for complex reasons before trying such an easy thing. So sorry!

That was the bit that gave the game away. My French is dreadful, but just about good enough for that!

1 Like