Feedback on version 0.33

This is the place to give us your thoughts and feedback on version 0.33 of Metabase.

If you’re running into trouble, be sure to check out our general FAQs and troubleshooting guide. If you’re totally new to Metabase, you can check out the Getting Started Guide.

If you have a specific feature request or bug report, please head over to GitHub to see if your issue has already been filed. If it hasn’t, you can create a new issue of your own.

2 Likes

In case you missed it, version 0.33 is now available!

1 Like

Enter Fullscreen Behavior Changed in 0.33.0 version

Earlier versions of hosted Metabase didn’t control native browser to occupy the entire screen space.
However, the latest Metabase version (0.33.0) expands the tab to enter into browser full-screen which is annoying.

P.S.: I prefer the dark theme for the dashboard which is only enabled when a dashboard is entered into full screen. But, that step is annoyingly useless as it undesirably makes the browser to enter full-screen!

Does anyone know how we can realize the behavior as available in the previous version?

1 Like

Hi there,

We’ve setup a parallel installation of Metabase 0.33 to test out all of the new features and it works smoothly. One of the persisting issues we currently have in our version (0.32.10) is the issues that was meant for Milestone 0.33 (https://github.com/metabase/metabase/issues/9955) that seems to be present in 0.33 as well unfortunately.

Other than that everything works fine even after the upgrade. Will try to provide more feedback as our users get to know the new query builder. Awesome work!

Team,

The first impression was “Oh no, this is not happening”. Simplicity was the signature of Metabase so far, but with this new change, it has become powerful. I am loving it.

With the new version (V 0.33) I am unable to add any dashboard filters. When I add a new dashboard filter of any type (like category or time), the filed list is disabled in the question and shows “No valid fields”.

Below is the editor view

Below if the dashboard filter page

What could be going wrong here?

Best Regards
Ranes

1 Like

I’ve experienced an issue with Conditional formatting in 0.33.
When I choose to highlight only the selected column, then the column is not highlighted at all:


However, if I switch on “Highlight the whole row”, then only a couple of first columns are highlighted:

The installation on AWS ElasticBeanStalk is broken. It results in a 502 Gateway Error after all the processes complete.

I’ve tried it multiple times.

My bad. The timezone was incorrect which resulted in a shutdown of Metabase. A bit weird though, it should switch back to UTC.

I think there’s something going on with what columns Metabase thinks are available for a dashboard filter to connect to. In the testing I’ve just done, it seems like only columns from the original table are available in a scenario like the one in your example; not columns from any of the joined data.

Since your example shows a Category filter widget on that dashboard, it must be that the Tab Resource Time Sheet table doesn’t have any valid category columns. If you instead try adding a Date filter widget, are you seeing the option to connect it to the Work Date column from the Tab Resource Time Sheet table? If so, I think that would confirm my hunch.

Looks like the improvemment were only about UX and tables join, I was expecting to be able to do year-over-year calculate or percentage over total without resorting to SQL.

Hi. Since I upgraded to 0.33, I have been unable to see my logs. The error looks quite Javascripty. Should I create an issue in Github?

Where and how are you running Metabase? I’m not seeing this after a cursory look at the instance I’m running locally or the one our team uses internally.

Might have just been a fluke. I refreshed a bunch of times to no avail, then I went to lunch, refreshed again, and voila! Back to normal. I’ll make a GitHub issue when and if I see it again, and I’ll be sure tin include the Javascript console output. I’m running Metabase in Elastic Beanstalk.

1 Like

Thanks for bringing the conditional formatting bug to our attention. I filed the bug and we’re just verifying a fix for it which we’ll merge shortly.

How do I stop it displaying graphs. We want tables. table always…

Hello @maz I did try with Work Date, but the issue persists.

Best Regards
Ranes

After upgrading to 0.33 some of my queries (answers) stopped working and return no results. After investigating (converting no native). I think the converted query has a error:

[
  {
    "$project": {
      ...
      "orderdate~~~year": {
        "$let": {
          "vars": { "column": "$orderdate" },
          "in": {
            "___date": {
              "$dateToString": { "format": "%Y", "date": "$$column" }
            }
          }
        }
      }
    }
  },
  { "$match": { "orderdate~~~year": { "$eq": { "___date": "2019-01-01" } } } },

  ... removed for brevity ...

the $match shoudn’t be something like?:

{ "$match": { "orderdate~~~year": { "$eq": { "___date": "2019" } } } },

there’s a miss match between format and filter.

@kimus I think you’ve found a bug. Can you create an issue on Github? I think it might have been caused by PR 10561, which tried to fix an old issue, so maybe "format": "%Y" should be "format": "%Y-%m-%d" for this to play nice.

Thanks, I’ve created the issue in https://github.com/metabase/metabase/issues/10683

1 Like

Chinese language disappear,It is planned?