Field Filter - Problem with sintax

Hi all,

i need help with Field Filter, I already did others questions with Field Filter , but only that question not be work.


i write this:

[[where A.description = {{Status_SIP}}]]

and returned for me:


I tested the same query without variable and in place of the variable I put one of the column items and it worked


WHERE 1=1 and {{Status_SIP}}

Assuming you’ve correctly mapped Status_SIP to Description like this:

With selection the field not worked, but if i don’t select any field worked

If you’ve mapped the filter to a field as in my picture, you don’t need the A.Description part.
Your resulting SQL will be something like:

 where A.description = A.Description = 'MyValue'

I’m wondering if this should actually be promoted into a #feature-requests-and-suggestions topic?

Bumped into yet another person the other day with similar problem, see my comment and original post in GitHub issue #8144 here. If you search GitHub and probably also Discourse here it at least seems pretty FAQ.


edit: @Hlopes try to read up on the User Guide page I pointed to in the #8144 link above. When I last tried a while ago it seemed the order of doing stuff in the SQL window versus the Variables panel mattered - some magic is going on behind the scene. I had to start from the beginning a few times.

I try where {{sip}} and not worked