Field Filter's string widget type doesn't work per expect

Hey there,

We found the box of string widget type is not stable, sometimes it can loads the dropdown list with options (which is the expected behavior, see img_1) while sometimes it loads nothing but a search text line, which really drives us crazy as it is not doable for user to input the whole chars.


The type of fields that show unexpected behavior is Category

The field's filtering type is "A List of All Values"

Also rescan the field but still doesn't work

The filter widget type is "String" (as opposed to "Category" per your latest document) as my version is 0.43 which doesn't have "Category" - is this the reason?

If the number of distinct value is greater than 300 then dropdown list is not avialble no matter how do we configure the system, right?

Hi @xuheng925
Post "Diagnostic Info" from Admin > Troubleshooting.
Latest release is 0.44.6. There has been many changed to dropdown, so it will show up to 1000 (if the combined length is less than 100kb).

Thanks @flamber. Updated to the latest version and the dropdown works now..

One more question - Let's say the number of distinct value of the column is 1500, the system shows no dropdown at all (just the search line), or it still shows dropdown with only 1000 of the 1500 values where user can use search to find whatever values be it in the 1000s or in the 500s?

@xuheng925 Only 1000 values are available in the dropdown. If you have more, then use Search.

Got it, thanks! That makes lots of sense!