Filter Autocomplete suggestions does not work


#1

I added a category filter called name to my dashboard. When I click the filter to enter the name I want to filter on, the autocomplete suggestion does not work.

This is blocking my team from using the dashboard. Indeed, we have many data with similar names and I would like the team to be able to find all data with same or similar names. Since the filter is based on a “name is X” rule, and not “name contains X” rule, they would have to enter the same exact name for it to work and that will lead to mistakes.


#2

Have you setup the column defined to be Search box under Filtering on this field in Settings > Admin > Data Model > (database) > (table) > (column) ?
What’s the Field Type of the column?

Which version of Metabase? Which database do you connect to?


#3

Thank you redefining the “filtering on this field” to Search box helped a lot


#4

Other question if I may, I have an email field in my table. I am trying to add a filter on this email field as well in my dashboard. But when I configure my filter, then I cannot select the email field to be filtered on.
From the Admin panel > Data model, in the Email - field settings I have: Filed type = email ; filtering on this field = Search box. Can you help me troubleshoot? many thanks


#5

@Mathilde
In your database, what is the actual type of that column? CHAR, VARCHAR, TEXT, …?
Also, which version of Metabase are you using and what type is your datasource?


#6

@Mathilde
Scratch that. Change the Field Type to anything but Email (example No special type) - seems like a bug, I’ll investigate.
Edit: There’s an issue here. Quick solution is to set the column to Category


#7

Thank you ! Indeed it worked.