Filter values are not being passed to BigQuery for custom SQL

First off I have to say you guys have put together a terrific product. I have only recently started using Metabase but I couldn’t believe my eyes when I saw how beautiful the UI and visualizations are. Now to the point. When I’m writing custom SQL on bigquery with variables, the variables don’t seem to get replaced with the values but is getting passed as is, and the query fails. Attaching some screen shots here. Am I doing something wrong here? Thanks in advance.

We actually don't support paramteres for BQ quite yet. There was a mistake in exposing that panel for BQ. We're working on it for the next release (0.21) however.

Great, thanks. Looking forward to it.

Any update on when this feature will be supported? I see from the ticket that it didn’t end up in the 0.21 milestone, and that it was also removed from 0.22.


Waiting for the update !!


I've tried to use {{variables}} in Metabase with BigQuery. Looks like they are still not supported, any plans for such integration in the near future?