Filtering on this fiel "A list of all values" not showing in the List Widget

Dear Metabase Team & Community,

Thanks a lot for the amazing work and product!

I write a message because after some research I don’t find the solution… Hope you can help me.

I have a filter that doesn’t show the full list of values in my field.

I have seen the issues solved in 0.29

If I understand correctly, the limit can be 5000 values shown in the dropdown list ?

So my field has a “Product” type, and have the following fingerprint


Has field values is set to “list”

When a run a SELECT distinct product_name on this field, I have an outcome of 1105 values.

Is it normal that it is not showing on the dropdown list?

Thanks a lot for your help.

Have a great evening


Hi @romain9292
Please post “Diagnostic Info” from Admin > Troubleshooting.

What do you mean by “doesn’t show the full list of values”?
If I remember correctly, it will automatically change the list to a search input if there’s more than 100 values.

Do you have any null values? Then you’re likely seeing this issue:

Hi Flamber,

Thanks a lot for your answer.

This is correct: “it will automatically change the list to a search input if there’s more than 100 values.”

But we can display all values for more than 100 inputs in the list filter widget.
And according to
You should be able to display even more than 100.

No null values or missing values.

Oh and we are using bigquery and metabase v 0.34.2

Thanks again !

@romain9292 Try with the latest release 0.35.3, and do a forced sync+scan (Admin > Databases > your-bq) and check the log for errors (Admin > Troubleshooting > Logs)

Hi Flamber,

Tried on 0.35.3, discard cached value + force sync + scan.

Still converting the field filter list to a search box.

No error logs :frowning:

Should I open a ticket on Github?

Thanks for the help !

@romain9292 Seems like the limit is 300 - I get a list of 200 items, but a search box for one with 1800 items.

As for the reason for the difference of 381 vs 1105, I’m not sure why that’s happening.
It should be doing SELECT column FROM table GROUP BY column LIMIT 5000
It would probably help if you checked your query log to see what Metabase is querying and what the result is send

Thanks a lot for your time and answer.

Will try to get more informations with the logs !

Thanks again !

For reference: