Filters not presenting list


I have set a field to list all values when used as a filter. When I incorporate this as a filter in either a dashboard or a question is still showing as a search.
Is there anything else I need to change in the configuration?

I am using BigQuery - Thank you

Hi @Antonio89

Which version of Metabase? Do you see any errors in the Metabase log or browser console?

What is the Field Type?

So even when you go to the question, then the filter still just shows a search instead of a dropdown?
Then we can ignore the dashboard for now, since that just makes everything more complicated.

And the Field Filter column reference in the side panel is the same as the one you set to “list all values”?

EDIT: Have you tried refreshing your browser window?

Morning @flamber

When using a filter by asking a question or creating a filter using the SQL editor neither appears as a list, just a search box. I have refreshed, resynced and cleared the cache and this issue is still there.


Which version of Metabase?

Do you see any errors in the Metabase log (Admin > Troubleshooting) or browser console?
Specifically when it’s syncing - otherwise try forcing a sync again.
Admin > Databases > Sync database schema now

version is 0.32.10

I will review the troubleshooting and resync

Sometimes, it happens when your filter is connected to different columns and they don’t match perfectly.

Unfortunately still having issues with this

Platform field config:

Query as is (filter is freetype)

Changed Query to Field Filter and the filter box vanishes:

Would be awesome if I could get this solved as I will be able to give a live demo.

Thanks and sorry to be a pain!!!

Just to add, we are using BigQuery behind Metabase

You need to set Field Type to one of the required types:
And the query is wrong when using Field Filters - it should just be [[AND {{Platform}}]]:

Makes sense as I changed the field type and that coincided with the filter prompt not being visible

I have changed the config of the column but still have issues with the field presenting a list

In the last image I created a fresh question

How many items does your table contains? It will only show a list if there a less then …?If you put in a value that exstist does your filter work?

108,966 Rows in total
5 Distinct values

@Antonio89 Make sure it’s sync’ed correctly. Check the log.

hello folks
i have exactly the same issue like Antonio.
My Dashboard filter does not show any list (just the text search).

The List should provide currently around 1.000 entries. (but could potentially have 10.000 entries as well)
In general the filter works if i enter a known value.
I don’t have this issue whenever the list is smaller than e.g. 200 entries or so…

Can it be that there is a limitation in terms of maximum amount of values in the list ?

version i use is v0.33.6