Force metabase to show table, not card


#1

Hi there, people!
How can I get table rows, instead of the card view?

I simply can’t see my records this way. Is there any workaround?


#2

This is happening to me whenever I try to filter results based on a unique field… :frowning:


#3

Hi @lucas.lima
It’s because of the Primary Key. I cannot find an issue about this, so you might want to create a feature request.
But as a workaround, you can create a Saved Question (Nested Query) and use that as your source.


#4

It happens when you filter on the Primary Key (Entity key).

Two workarounds:

  1. Change the report to SQL (no need to change the SQL, it just stops doing it)
  2. Filter on something else - not as daft as it sounds, if you can create a view instead, just have a 2nd column with a copy of the primary key.

Would be better to have an option to turn it off, but until then…


#5

Oh, thanks, guys!
I’ve been able to just remove the Entity key (possible in my case). Thanks for the support - I’ve filed an issue.